
The Intermediate Guide to
Microsoft Access 2013
Microsoft Offi ce Specialist Exam 77-424 Study Guide

another
Computer 

Mama
Guide

© 2014 Comma Productions, LLC



. The Intermediate Guide to Microsoft Access 2013
© 2014 Comma Productions, LLC 
9090 Chilson Road
Brighton, MI 48116
978-0-9891924-0-8
Trademark and Copyright
Microsoft Word ® , Microsoft Excel ®, Microsoft Access ®, Microsoft Outlook ®, Microsoft PowerPoint ®, 
Microsoft Windows ®  are trademarks or registered trademark of Microsoft Corporation. Adobe Photoshop® 
and Acrobat® are trademarks or register trademarks of Adobe Corporation. 

Limit of Liability/Disclaimer of Warranty: 
The Publisher and Author make no representation or warranties with respect to the accuracy or 
completeness of the contents of this work and specifically disclaim all warranties including without limitations 
warranties of fitness for a particular purpose. The advice and strategies contained herein may not be 
suitable for every situation. The fact that an organization is referred to in this work as a citation and/or 
potential source of further information does not mean that the authors or publisher endorses the information 
that the organization or website may provide or recommendations it may make. Readers should be aware 
that Internet websites listed in this work may have changed or disappeared between when this work was 
written and when it is read.

Neither Comma Productions nor Author shall be liable for any loss of profit or any other commercial 
damages including but not limited to special, incidental, consequential or other damages.

Comma Training Page 2



The Intermediate Guide to Microsoft Access 2013
Chapter 1: Getting Started
Take 1: Hello, Again, Hello, page 11
Objectives and Menu Map, page 12

Take 2: One-From-Many Relationships, page 27
Objectives and Menu Map, page 28
Practice Activity, page 53
Test Yourself, page 54

Chapter 2: Representing One-to-Many in Form Design
Take 1: Forms and Subforms, Part 1, page 55
Objectives and Menu Map, page 56
Practice Activity, page 85
Test Yourself, page 86

Take 2: Form and Subforms, Part 2, page 87
Objectives and Menu Map, page 88
Practice Activity, page 115
Test Yourself, page 116

Take 3: Synchronized Combo Boxes, page 117
Objectives and Menu Map, page 118
Practice Activity, page 151
Test Yourself, page 152

Chapter 3: Designing for Users
Take 1: Meet the Stars page 153 
Objectives and Menu Map, page 154
Practice Activity, page 187
Test Yourself, page 188

Take 2: The Opening Scene, page 189 
Objectives and Menu Map, page 190
Practice Activity, page 204
Test Yourself, page 204

Take 3: Dress Rehearsal, page 205 
Objectives and Menu Map, page 206
There is no Practice Activity for this lesson.
Test Yourself, page 220

Chapter 4: One-to-Many in Report Design
Take 1: Report Totals page 221 
Objectives and Menu Map, page 222
Practice Activity, page 249
Test Yourself, page 250

Take 2: Report Design Options , page 251 
Objectives and Menu Map, page 252
Practice Activity, page  276
Test Yourself, page 277

Intermediate Access Skill Test, page 279
Access Skill Test, continued, page 280

Microsoft Access 2013 Study Guide, page 7

Index, page 281

Comma Training Page 3

Microsoft Access 2013 Inermediate   Page 3 of 281



What is the Microsoft Office Specialist Certification Program?
The Microsoft Office Specialist (MOS) Certification Program enables candidates to show that they have something 
exceptional to offer – proven expertise in Microsoft Office programs. Recognized by businesses and schools around the 
world, millions of certifications have been obtained in over 100 different countries. The Microsoft Office Specialist 
(MOS) Certification Program is the only Microsoft-approved certification program of its kind.

The Microsoft Office Specialist Certification Series
Core Certification: Pass any 1 test:
Word 2013 Core: Exam 77-418
Excel® 2013 Core: Exam 77-420
PowerPoint® 2013: Exam 77-422
Outlook® 2013: Exam 77-423
Access® 2013: Exam 77-424

Expert Certification: Pass either test:
Word 2013 Expert Part 1: Exam 77-425
Word 2013 Expert Part 2: Exam 77-426
Excel 2013 Expert Part 1: Exam 77-427
Excel 2013 Expert Part 2: Exam 77-428

Master: Pass 3 required and 1 elective test:
Required
Word 2013 Expert Part 1: Exam 77-425
Excel 2013 Expert Part 1: Exam 77-427
PowerPoint® 2013: Exam 77-422

Elective
Outlook® 2013: Exam 77-423 or 
Access® 2013: Exam 77-424

Please Note: Comma Productions, LLC. is independent from Microsoft Corporation, and not affiliated with Microsoft in any manner. While the Complete 
Computer Guides may be used in assisting individuals to prepare for a Microsoft Office Specialist Certification exam, Microsoft, its designated program 
administrator, and Comma Productions, LLC. do not warrant that use of these Complete Computer Guides will ensure passing a Microsoft Office Specialist 
Certification exam.

Microsoft Office Specialist Certification

What is Microsoft Office Specialist 
Certification? Microsoft Office Specialist 
certification validates through the use of 
exams that you have obtained specific skill 
sets within the applicable Microsoft Office 
programs and other Microsoft programs 
included in the Microsoft Office Specialist 
Program. The candidate can choose which 
exam(s) they want to take according to 
which skills they want to validate. 

CertiPort is the premier provider for 
validating technology skills. 

The Microsoft Office Specialist tests are 
offered at authorized testing centers.

For more information on the MOS exam 
topics or to find a testing center near you 
please contact: www.certiport.com
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The Benefits of Certification
Why Get Certified?
For employers, the certification provides skill-verification tools that not only help assess a person's skills in using Microsoft 
Office programs but also the ability to quickly complete on-the-job tasks across multiple programs in the Microsoft Office 
system. (http://www.microsoft.com/learning/en/us/certification/mos.aspx).  Certification proves a certain level of advanced 
competency with the programs in question.  Employers don’t have to wonder if the skills stated on the resume are honest 
and without exaggeration.  This can lead to further employment opportunities and increased pay.  

A person holding Microsoft Office Certification shows not just a level of skill, but an ability to quickly complete tasks, due 
to familiarity with the program and it’s many time-saving features.  The hard work that goes into learning Microsoft Office 
programs to the level of proficiency necessary for successful completion of the Certification Exams also indicates a desire 
on behalf of the student to learn and succeed.   

The Benefits: Earn More, Find Jobs Quicker
Research indicates that employees with Microsoft Certification earn more and find jobs quicker than those employees 
without certification.  Furthermore, employees with certification report a greater feeling of confidence.  These things 
translate into greater job satisfaction.  (http://www.microsoft.com/learning/en/us/certification/mos.aspx)

Research also shows that individuals with certification make up to 12% more than those without certification.  In addition, 
82% of Microsoft Office Specialists report a salary increase after receiving certification.  Managers like the skills proven 
and the ability demonstrated by those with Microsoft Office Certifications.  
http://www.certiport.com/Portal/desktopdefault.aspx?page=common/pagelibrary/mos2003.html

For More Information:
www.certiport.com
www.microsoft.com
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About Our Certification Program
Microsoft Office Specialist (MOS) Certification for Access 2013
Overview: Our Microsoft Office Specialist certification program for Access 2013 covers all of the exam objectives for the 
Access certification exam. Microsoft Office Specialist exam 77-424 for Access is an elective exam that demonstrates 
expert knowledge of database programming and Microsoft Office automation. It is not required for MOS certification. 

Our Approach: In designing these Guides, we found that it made more sense to write the lessons based on the Ribbons 
and Tasks. The beginning of each lesson provides an overview of the Ribbons and Tasks covered.  

The Beginning Guide to Microsoft Access 2013 demonstrates the following Ribbons: Home, Create, Table Tools, 
Form Layout Tools: Arrange and Format, Query Tools, and Report Layout Tools. The lesson activities focus on 
basic database objects: Tables, Forms, Queries and Reports.

The Intermediate Guide to Microsoft Access 2013 demonstrates the following Ribbons: Table Tools, Form Design 
Tools: Arrange and Format, Query Tools, Report Design Tools and the Macro Tools.  The programming focuses on 
representing one-to-many relationships: Form and Subform, Report and Subreport. The lessons show how to design for 
Real Users that includes creating a Switchboard that opens when the database is launched.

The Advanced Guide to Microsoft Access 2013 begins with a discussion of how to design a database in Third Normal 
Form to minimize repeat data and reduce errors. The programming focuses on using Key data to create relationships 
between Tables. The projects include a Receipt Form that calculates the total amount owed and a Receipt Printout 
formatted for a small Point of Sale (POS) printer.

Course Prerequisites: Students who enroll in the Microsoft Access 2013 program should have strong computer skills 
including how to use an Internet browser and how to select commands from a menu. Students should know how to save 
files and send attachments by email as well. In addition, students should have good skills with spreadsheets. 

Books in this Series:
Beginning Guide to 
Microsoft® Access 2013

Intermediate Guide to 
Microsoft® Access 2013

Advanced Guide to 
Microsoft® Access 2013
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Microsoft Access 2013 Study Guide
             Microsoft Office Specialist (MOS): Exam 77-424 for Access 2013

3.0 Create Queries 
3.1 Create a Query
Queries: Create a Crosstab Query, Pg 248
Queries: Create an Action Query, Pg 44
Queries: Delete a Query, Pg 304
Queries: Rename a Query, Pg 302

3.2 Modify a Query
Queries: Hide Fields, Pg 289

3.3 Utilize Calculated Fields and Grouping
3.3 Use Calculated Fields and Grouping, Pg 286
Queries: Use Comparison Operators, Pg 222
Queries: Use Basic Operators (Add, Subtract, Multiply, 
Divide), Pg 166

4.0 Create Forms 
4.1 Create a Form 
Forms: Create Forms with Application Parts, Pg 65
Forms: Delete a Form, Pg 318

4.3 Format a Form 
Forms: Change Margins, Pg 105

5.0 Create Reports
5.1 Create a Report
Reports: Create a Report with Application Parts, Pg 204
Reports: Delete a Report, Pg 318

5.2 Set Report Controls
Reports: Add a Subreport, Pg 204
Reports: Modify Data Source, Pg 168

5.3 Format a  Report
Reports: Set Margins, Pg 170 

Study Guide Page 1 -Page 2
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Microsoft Access 2013 Study Guide
             Microsoft Office Specialist (MOS): Exam 77-424 for Access 2013 

1.0 Create and Manage a Database 
1.2 Manage Relationships and Keys 
Relationships: Create and Modify Relationships, Pg 80
Relationships: Enforce Referential Integrity, Pg 81
Relationships: Set Foreign Keys, Pg 39
Relationships: View Relationships, Pg 76

1.4 Protect and Maintain a Database 
Protect and Maintain: Compact, Pg 341
Protect and Maintain: Repair, Pg 341
Protect and Maintain: Backup, Pg 292
Protect and Maintain: Split, Pg 326
Protect and Maintain: Encrypt with a Password, Pg 335

1.5 Print and Export a Database 
Print and Export: Print Reports, Pg 336
Print and Export: Save Database to an External 
Location, Pg 316
Print and Export: Export into Alternate Formats, Pg 255

2.0 Build Tables 
2.1 Create Tables 
Tables: Create a Table, Pg 73
Tables: Create Linked Tables from External Sources, Pg 322

2.2 Format a Table
Tables: Format a Table, Pg 57
Tables: Hide Fields, Pg 56
Tables: Change Data Format, Pg 296

2.3 Manage Records 
Manage Records: Update Records, Pg 45
Manage Records: Append Records, Pg 282
Manage Records: Group Records, Pg 165

2.4 Create and Modify Fields
Tables: Change Field Data Types, Pg 296

Study Guide Page 1 -Page 2
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 How To Use This Guide

The Comma Method
Observation is a perceptual strategy that asks: why am I doing this 
and which tools would be most effective? Each lesson begins with 
a discussion of the purpose and the objectives.

Orientation helps students start at the right place. The screen 
shots in the Complete Compute Guides show the entire window as 
well as a close up of the particular button or command. 

Notation There are "breadcrumbs" above each screen image. Like 
Hansel and Gretel, the breadcrumbs show the pathway to a button 
or option. Our notation uses the following convention:
Ribbon->Group->Button->Options

Menu Maps
The Comma Method recognizes that there is a difference in how 
men and women navigate the menus. Men typically have the ability 
to see the map first. This method of acquiring knowledge is called 
Breadth-first. [1] Women tend to work with the details first. They 
learn several commands, such as copy, cut, and paste, then they 
put those concepts under the label, “edit.” This method of learning 
is called Depth-first. 

The Comma Method uses menu mapping to assist men and 
women to see both the Breadth and the Depth. An example of the 
menu map is can be seen here.

[1] Ford, Nigel, Sherry Chen, Matching/mismatching revisited: An Empirical Study of Learning and Teaching 
Styles. British Journal of Educational Technology v.32 no1 (Jan. 2001)

Query Tools->Design
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© 2014 Comma Productions, LLC

Access 2013: Getting Started

Intermediate Access Objectives
An overview of the lessons in this book: 
1. Representing a one-to-many 
relationship with a Form and Subform.
2. Using a Query Criteria to make a 
Combo Box that looks up a value on a 
Form.
3. Creating a blank Form and adding 
buttons to open Forms and Reports.
4. Finding common errors in Forms and 
Queries and correcting the mistakes.

5. Calculating Totals in a Report.

Hello, Again, Hello
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1. Readings
Read Lesson 1 in the Intermediate Access 
guide, page 11-26

Project
This overview does not have a 
demonstration project.

Downloads
There are no downloads for this lesson.

2. Practice
There is no Practice Activity for this lesson.

3. Assessment
There is no test for this lesson.

Lesson 1 : Hello, Again, Hello
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Sample Microsoft Office Access 2013 Form

Learning Microsoft Access is different than mastering the rest of the Microsoft Office suite. Each 
objective in PowerPoint can be explained and demonstrated in a couple dozen pages. In contrast, it 
takes a whole book of programming to make a database useful.

One goal of the Intermediate Access programming is to create Forms and Reports that search the 
movies. Another goal is to make the database User Friendly. This lesson offers a summary of each 
step in the process is, why that method was chosen, and what the outcome should be. 

Working with Databases
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Goals and Objectives
The Beginning Guide to Microsoft Access 
2013 introduced the database objects: 
Tables, Queries, Forms and Reports. These 
lessons showed a one-to-one relationship. 
The Movies Form has one Record Source: 
the Movie Table, tblMovies. 

The Intermediate Guide to Microsoft 
Access 2013 demonstrates several 
methods of representing one-to-many 
relationships. For example, there are many 
movies with the same rating, say "PG," 

What Is The Best Approach? These lessons 
will create several Forms and Reports that 
look up important information. These lessons 
will also focus on the User Interface. Simple 
programming can make a Form much easier 
to use. 

Example of a Form with a Combo Button
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Before You Begin:
Draw A Data Diagram
Each object in a database either looks up the 
information in a Table or modifies the 
information in the Table. 

These lessons will build Forms with Subforms. A 
Subform is a Form that is added to another 
Form. The two Forms are linked by Fields that 
both share. This is how a relational database 
represents a one-to-many relationship. 

Each Form and Subform will have a different 
Record Source, so it is important to keep track of 
which Table or Query goes with which Form or 
Report.

A data diagram helps organize your plans. It is 
a simplified sketch of what you would see when 
the Forms are in Design View.  

Example of a data diagram: The arrows show the Record Source 
for the Forms and the Control Source for the Combo Box.
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Name Objects Consistently 
Name Objects Consistently: Use a naming strategy 
that includes the Object.

Why Does This Matter? When you review the 
Record Source in the Property Sheet, you will 
discover to your dismay that the Objects are not 
sorted and identified as Tables or Queries. 

If you use a consistent naming strategy when you 
name the Tables and Queries it will be very easy to 
identify what type of Object (Table or Query) it is in the 
Property Sheet. 

The same method should be used when you name the 
Primary Key. It should include the name of the Table it 
goes with. In our lessons we will rename the Primary 
Key in the Rating Table from ID to RatingID.

The Computer Mama Also Sez: Using the default, 
ID, for all of the Primary Keys is like naming all of your 
sons "Dave."

Sample of a Property Sheet for a Form. The Record Source is selected
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One-From-Many Relationships:
The Rating Combo Box 
Use a Table to Add Data to Another Table
This lesson will add a Combo Box to the Movie Form. 
The Combo Box will select data from the Rating Table 
and add the Rating to the Movie Table. 

What Are the Steps? 
Create a Rating Table and add the Rating data. 
Add a Rating Combo Box to the Movie Form. 
Troubleshoot the Combo Box Properties.

What Are the Issues? The Combo Box Wizard does 
NOT always choose the Field that matches. This lesson 
shows one method for selecting the Field that matches. 

What is the Key Concept? The focus of this lesson is 
on the data. Each Field in a Table has a specific data 
type: Number, Text, Date, etc. 

When you add data from one Table to another the data 
has to be the same type. Text goes with Text. Numbers 
go with Numbers.

Sample of a Form with a Combo Box Control
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Forms and Subforms:
Purpose of This Programming 
The lessons will create a Search Form that lets Users 
look up Movies by the Genre and Rating. 

The three Form and Subform lessons will program 
several Forms and Controls to:

Create a Form and Subform
Forms and Subform Design Part 1 will design two 
Forms: The MovieSearch Form and a 
MovieSearchSubform. The MovieSearch Form has a 
new Table for the Record Source. The Movie Subform 
will use a Query for the Record Source. Both Forms 
will be formatted and tested.

Link the Form and Subform
Forms and Subform Design Part 2 demonstrates 
how to link a Form and Subform. The Movie Search 
Form will use a Combo Box to filter the data in the 
Movie Subform. 

Use a Query to Select Specific Data
Forms and Subform Design Part 3 adds a 
Synchronized Combo Box to the MovieSearch Form.

Example of the Completed Search Form
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Form and Subform Design, Part 1:
Create the Subform
Key Concept: Using a Query as a Record Source

Plan: The Subform will display the Movies as a list in 
Datasheet view. The Rating data will be formatted with 
Conditional Formatting

What Are the Steps? Create a Select Query for the 
Record Source and Test the Results. Then, create a 
Subform and edit the Property Sheet.

What Are the Issues? The Subform should be in 
Datasheet View. 

Why Use This Method? A Form can use either a Table 
or a Query for the Record Source. 

A Query lets you select, sort and filter the Records in 
the Subform. 

Example of the Movie Subform with Conditional Formatting
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Form and Subform Design, Part 1:
Create the Form
Key Concept: Use a Combo Box Control to look up 
data in one Table and add it to another Table.

Plan: The Form will enable Users to search for Movies 
by Rating. This Form will have a new Table, 
tblMovieSearch, as the Record Source. 

What Are the Steps?
Create a new Table for the Movie Search Form. 
Create a new Form based on tblMovieSearch.

Create a new Table for the Rating data.
Use tblRating as the Control Source for a Combo Box 
on the MovieSearch Form. 

What Are the Issues? This Form should be in Single 
Form View. 

Why Use This Method? A Combo Box Control is an 
effective way to look up the data in a Table. When a 
User selects a value from a Table it is accurate and 
spelled right. 

Example of the Rating Combo Box on the MovieSearch Form
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Form and Subform Design, Part 2:
Link the Form and Subform
Key Concept: Use a Form Control to add the 
MovieSearchSubform to the MovieSearch Form. 

Plan: Link the Form and Subform by three Fields to 
create a one-to-many relationship.

What Are the Steps?
Use the Subform Wizard to Link the Forms
Select the Subform
Define the common Field: Rating

Review the Subform Properties 
Confirm the Master and Child Links
Test the Movie Search Form

Automate the Form with a Macro
Troubleshoot the Programming

What Are the Issues? The Control Automation will be 
programmed with Embedded Macros. The new Macro 
Editor uses forms to help write the Code.

Example of the Form and Subform Links in the Property Sheet
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Form and Subform Design, Part 3:
Synchronized Combo Boxes
Key Concept: Use the Query Criteria to look up a value 
on a Form.

Plan: Synchronize two Combo Boxes and Filter the 
Records in the MovieSearchSubform.

What Are the Steps?
Create a Table for the Genre. 
Create a Query for the second Combo Box.
Use the Expression Builder to write a Criteria that looks 
up a Field on the MovieSearchForm.

Create a Genre Combo Box
Automate the Form with a Macro
Test the Movie Search Form
Troubleshoot the Programming

What Are the Issues? Many of the Movie Records are 
incomplete: they have no Genre data. So, the Query 
needs to filter out the Movies that do not have a Genre 
with a Criteria.

Example of a Query that synchronizes two Combo Boxes
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Designing for Users:
Meet the Stars
Key Concept: Use Command Buttons to open 
Forms and Reports from a Form.

Plan: Create a Switchboard Form.

What Are the Steps?
Create an Unbound Form.

Add Command Buttons:
To open two Forms: Movies, Customers.
To open one Report: Movies by Year

Add Buttons to Return to the Switchboard
From the Movies and Customers Form.

What Are the Issues? The Command Button 
Wizard creates Embedded Macros. 

Why Use This Method? Embedded Macros are 
the default in Microsoft Access 2010 and 2013. 

The Macros will be converted to Visual Basic 
(VBA) to demonstrate legacy programming. 

Example of the completed Switchboard Form
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Designing for Users:
The Opening Scene 
Key Concept: Program the User Interface for the 
Current Database.

Plan: Open the Switchboard Form when the 
database starts and hide the Navigation Pane. 
Edit the Form Properties to hide Selectors, 
Buttons and Controls when the Form opens.

What Are the Steps?
Set the Microsoft Access Application Options.
Select a Form to Display.
Test the start up settings.

Edit the Switchboard Form Properties
Hide the Record Selectors.
Hide the Navigation Buttons.
Hide the Windows Controls.

What Are the Issues?
Forms need to be tested again and again.

Screenshot of the Access Applications Options
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Designing for Users:
Testing Software
Key Concept: Use the Property Sheet to 
investigate Form Errors. 

Purpose: Identify programming errors.

What Are the Steps?
Create an error: misspell the Form Name.
Test the Control and Review the error.
Correct the error and test again.

What Are the Issues? All programmers need to 
learn how to troubleshoot mistakes. 

Why Use This Method? The Computer Mama 
suggests that kicking the computer to next 
Tuesday is not a winning strategy. This lesson 
offers a more scientific method. 

Sample of a spelling error
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One-to-Many: Report Design
Report Totals and Options
Key Concept: Add a Calculated Control to the 
Group Footer to show Totals.

Purpose: Use Sorting and Grouping to show 
One-to-Many relationships in a Report.

What Are the Steps?
Create a Report based on a Query.

Add Sorting and Grouping
Group the Movies by Genre
Sort the Movies by Year

Add Totals to the Report
Total Each Group
Total for the Report

Grab the cookies.
Let's get started!
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Access 2013: Designing Forms

Intermediate Access Objectives
In this lesson, you will learn how to: 
1. Create a new Table to use as a Record Source 
for a Combo Box Control.
2. Use the Combo Box Wizard to create a Bound 
Drop Down Control.
3. Edit the Combo Box with the Property Sheet.

One-from-Many Relationships
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1. Readings
Read Lesson 2 in the Intermediate Access 
guide, page 27-52

Project
Create a Combo Box with the Wizard.

Downloads
FrontRowVideo Int2.accdb
BBL Int ver2.accdb

2. Practice
Do the Practice Activity on page 53.

3. Assessment
Review the Test questions on page 54.

Menu Maps
From the Create Ribbon.
1. Create ->Tables->Table Design, page 34

From the Table Tools Ribbon
Table Tools ->Design->Views->View, page 35

From the Form Design Tools ->Design Ribbon
2. Form Design Tools ->Design->Controls->Combo Box, page 37

Create Ribbon

Form Design Tools

Lesson 2 : One-from-Many Relationships
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One-to-Many Relationships
The Beginning Guide to Microsoft Access 2013 demonstrated one-to-one relationships. There was one Table, tblMovies, for the Movie Form. 
There was another table, tblCustomers, for the Customer Form. Each Query had only one Table as well. This is a simplified approach to 
programming that introduced the database objects: Table, Query, Form and Report. 

In real life, most transactions are one-to-many relationships. For example, one customer may rent many movies. There are several ways to 
create a one-to-many relationship in Microsoft Access. The Intermediate Guide to Microsoft Access 2010 will demonstrate how to create Forms 
as well as Reports that show one-to-many relationships. 

Microsoft Office Access: Example of a Form with a Subform
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Data Entry: Form and Subform 
Forms and Subforms let Users record one-to-many 
transactions. For example, a Receipt Form has the 
customer's name on the top Form and the movies that 
were rented listed in the Subform on the bottom.

When business is good many customers return many 
times and rent many movies. A Receipt Form is also an 
example of a many-to-many relationship. So, we will 
spend some time on the Receipt Form in the Advanced 
Guide to Microsoft Access 2013. 

The Intermediate lessons will create two forms that work 
with the Movie Table: a data entry form and a search 
form. We will also add a little programming to the Form 
Controls so that the records update automatically when 
the User makes a selection.

So far, so good.

Microsoft Office Access: Example of a Form with a Subform in Design View
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Purpose of This Programming 
Forms and Form Controls are User-friendly tools to 
add, move or modify data from one Table to another. 
The Combo Box can use a Table or Query to look up, 
filter or select the data. 

The next three lessons will program several Combo 
Box Controls to do the following:

Use a Table to Add Data to Another Table
This lesson will create a Combo Box to the Movie 
Form. The Combo Box will be used to add data from 
the Rating Table to the Movie Table. 

Use a Table to Filter Data in Another Table
The next lesson will create a movie search form. This 
form will use a Combo Box to filter the data in the 
Movie Table.

Use a Query to Select Specific Data
A Query can be a Record Source for a Form as well. 
The following lesson modifies the movie search form 
with synchronized Combo Boxes. 

Microsoft Office Access: Example of a Form with a Combo Box Control
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: View All Access Objects

Before You Begin 
Before You Begin: Open the Sample Database
Go to Start ->Microsoft Access 2013.
Access will prompt you to open a database. 

This lesson uses the database that was created in the 
Beginning Guide to Microsoft Access 2013. If you 
finished those lessons you can continue with the same 
database that you saved or download the sample 
database at the beginning of this lesson. 

The  FrontRowVideo Int2.accdb database has:

Two Tables: tblCustomers, tblMovies

Four Queries: MovieSQ, MoviesByYearSQ, 
CustomerNameSQ and CustomerHomePhoneSQ

Two Forms: Customers, Movies

Two Reports: Movies by Year, Customer Name

Keep going....

Memo to Self: Click Enable Content if you see the 
Security Warning. 

Start -> Microsoft Access 2013

Comma Training Page 32

Microsoft Access 2013 Inermediate   Page 32 of 281



Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: View All Access Objects

Know Your Data 
Try This: Review tblMovies
Go to All Access Objects ->Tables.
Select a Table: tblMovies
Double-click the Table to open it in Datasheet View.

What Do You See? There are 401 records in tblMovies. 
There are Fields for Rating and Genre. 

Close tblMovies.

Keep going...

All Access Objects ->Tables
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Exam 77-424: Microsoft Access 2013
2.0 Build Tables 
2.1 Create a Table: Create New Tables

Use a Table to Add Data 
A Combo Box can look up data from a Table or 
a Query. This example will look up movie ratings 
(G, PG, R) from a Rating Table. First, let's create 
the Rating Table. 

1. Try it: Create a Rating Table
Go to Create ->Tables->Table Design.

A new, blank Table will open in Design View. 
The Table Tools should be available. 

Try This, Too: Add the Fields
Field Name: RatingID
Data Type: AutoNumber
Go to Table Tools->Table->Primary Key.
Field Name: Rating
Data Type: Short Text

Do This, Now: Save the Table
Go to File->Save.
Enter the name: tblRating.

Keep going..

Create ->Tables->Table Design
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Exam 77-424: Microsoft Access 2013
2.0 Build Tables 
2.3 Manage Records: Add Records

Add Data to the Table 
Before You Begin: Change the View
Go to Table Tools->Design->Views->View.
Select a View: Datasheet

2. Try it: Add Data to the Table
Enter the following in the Ratings column:
G
PG
PG13
PG14
PG15
R
X
NR

What Do You See? Access added an 
AutoNumber to each new record.

Close tblRating. Keep going...

Memo to Self: The information in the Rating 
Table is considered static data: It does not change 
very often. Does the Rating table need a Form for 
data entry? Probably not. 

Table Tools ->Design->Views->View
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Delete Form Controls

Open the Form in Design View
A Combo Box can look up data from one table and 
add it to another. This example will use a Combo 
Box to add the Rating from tblRating to tblMovies. 
Start by opening the Form. 

3. Try it: Open the Form in Design View
Go to All Access Objects->Forms.
Select a Form: Movies

Go to Home->View->Views.
Select a View: Design View.

What Do You See? The Movie Form has a 
Control for Rating. It is a Text Box. 

The goal of this programming is to delete the Text 
Box and replace it with a Combo Box so that the 
User can simply choose the answer from the list 
instead of typing it into the box. 

Try This: Too: Delete Two Fields
Select the Rating Field and delete it. 
Please delete the Control and the Label for the 
Rating Field. 

Keep going...

Home->View->Views->Design View
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms
4.2 Set Form Controls: Add Form Controls

Use the Data in a Combo Box
The Rating Combo will look up the ratings from 
tblRating. This example will use the Combo Box 
Wizard to select the Record Source and the 
Fields. 

Something to Look For: There are actually 
seven steps to the Combo Box Wizard, however, 
the next to last step may be skipped! Here are 
the steps, clues and options. 

Try it: Create a Rating Combo Box
The Movie Form is open in Design View.
Go to Form Design Tools ->Design.
Select a Control: Combo Box.

And Do This: Start the Wizard
Click on the Detail Section of the Form. 
The Combo Box Wizard should start. 

Keep going...

Form Design Tools ->Design->Controls->Combo Box
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms
4.2 Set Form Controls: Add Form Controls

Combo Wizard: Which Data?
There are three ways to get the data for the 
Combo Box. The Combo Wizard prompts you to 
choose from the following: 
From another Table or Query
Type the values in a new list
Find a Record.

1. Try it: Choose a Method
Select: I want the combo box to get the values 
from another table or query.

Click Next. 

Keep going...

Form Design Tools ->Design->Controls->Combo Box
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms
4.2 Set Form Controls: Add Form Controls (Select Record Source)

Combo Wizard: Select a Table 
2. Try it: Select a Table
Select a Table: tblRating

Click Next. 

Keep going...

Form Design Tools ->Design->Controls->Combo Box
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms
4.2 Set Form Controls: Add Form Controls (Select Fields)

Combo Wizard: Select Fields
3. Try it: Select the Fields
There are two Fields in tblRating:
RatingID (a number)
Rating (text)

Use the arrow to select both Fields.
Click Next. 

Keep going...

Form Design Tools ->Design->Controls->Combo Box
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms
4.2 Set Form Controls: Add Form Controls (Sort Records)

Combo Wizard: Sort the Fields 
You can Sort the Fields in the Combo Box List. 
There are three Sort levels. Each level can be 
sorted Ascending (A-Z) or Descending.

4. Try it: Sort the Fields
Select a Field to Sort: Rating
Select the Sort Order: Ascending

Click Next. 

Keep going...

Form Design Tools ->Design->Controls->Combo Box
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms
4.2 Set Form Controls: Add Form Controls (Hide Key Column))

Combo Wizard: Column Width
There are really TWO Columns in this Combo Box: 
RatingID and Rating. The RatingID Column is 
hidden because the Column width is 0 (zero). You 
can adjust the width of the Rating Column if you 
wish.

5. Try it: Adjust the Column Width
Adjust the Column: Make the Rating Column 
smaller by dragging the right edge.

What Do You See? By default there is a check 
mark to Hide key column. The key column in this 
example is RatingID.

Click Next. 

Keep going...

Form Design Tools ->Design->Controls->Combo Box
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms
4.2 Set Form Controls: Add Form Controls (Store Value)

Combo Wizard: Which Step? 
The next to last step in the Combo Box Wizard asks you 
to select which value to Store in your Table.

What Do You See? The list shows the Fields in 
tblMovies, the Record Source for the Movie Form. There 
is a Rating Field, which is TEXT. 

The Combo Box Wizard automatically picked the Primary 
Key from the Rating Table. The Primary Key, RatingID, is 
a NUMBER. 

RatingID doesn't match Rating. Text goes with Text. 
Numbers go with Numbers. 

The Wizard chose the Primary Key and the key Column 
was hidden. However, when you get to this step you 
cannot select the Field that matches.

How Did This Happen? This step is actually Step 7. The 
Combo Box Wizard assumed that the Control would save 
the key data, so it skipped Step 6, the one that asks you 
to choose a Field.

6. Try it: Go Back a Step
Click Back. See what was missed...

Form Design Tools ->Design->Controls->Combo Box
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms
4.2 Set Form Controls: Add Form Controls (Unhide Key Column)

Combo Wizard: Unhide key
The key column in this example is RatingID.

Do This: Unhide the Key Column
Uncheck the option: Hide Key Column 

What Do You See? There are two Columns.

Do This, Too: Resize the Key Column
Drag the right edge of the RatingID Column to 
make the width 0 (zero.) A zero width hides 
the Key Column, again, so the user only sees 
the Rating Column. 

Click Next. 

Keep going...

Memo to Self: When you Unhide the key 
column, then you get to choose which Field 
you want to store at the end of the Combo 
Wizard. 

Form Design Tools ->Design->Controls->Combo Box
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms
4.2 Set Form Controls: Add Form Controls (Select Bound Control)

The Missing Step in the
Combo Box Wizard: 
Select the Field to Store 
Going back and resizing the key column brings up 
the missing step and the option to select which 
Field you wish to store.

The Combo Box Wizard default is to select the key 
column, Rating ID. However the tblMovies stores 
the Rating (G, PG, R), which is Text, and not the 
RatingID, which is a Number.

Match. Match. Match. The answers from the 
Combo Box have to match the data type of the 
Field in the Table. Text always goes with Text. 
Numbers always go with Numbers. 

They have to match. 

7. Try it: Select a Field to Store
Select a Field: Rating
Click Next. 

Keep going...

Form Design Tools ->Design->Controls->Combo Box
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms
4.2 Set Form Controls: Add Form Controls (Store Value)

Combo Wizard: Store Value 
Now...you can store (save) the value selected 
from tblRating to the value in tblMovies.

8. Try it: Store the Value
Select: Store that value in this field.
Choose a value: Rating

Click Next. 

Keep going...

Form Design Tools ->Design->Controls->Combo Box
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms
4.2 Set Form Controls: Add Form Controls (Edit Label)

Combo Wizard: Label 
The last step of the Combo Box Wizard asks to 
name this Control. 

9. Try it: Enter a Label for the Combo Box
Enter the name: Rating
Click Finish. 

Very good. Let's see if it works.

Form Design Tools ->Design->Controls->Combo Box
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Test the Form 
The programming on the Combo Box Control was 
written in Design View. Forms should be tested as 
the User sees them, in Form View.

Before You Begin: Change the View
Go to Form Design Tools ->Design->Views.
Choose a View: Form View. 

1. Try it: Test the Combo Box Control
The Movie Form is open in Form View.
Select a Rating: G

What Do You See? Can you see the list of 
ratings? Can you select one from the list?

So far, so good.  Keep going...

Where Have You Seen This Before? 
Microsoft Excel uses Data Validation to create a 
Drop Down List that looks up the values in a table. 

Form Design Tools ->Design->Views->View
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What If It Doesn't Work? 
2. Consider it: Troubleshoot a Combo Box
Say the Combo Control looks up the values in the 
Rating Table, tblRating. However, you see two 
columns, not one.

Worse, when you click on a Rating, say PG13, the 
Form displays a number, not the rating that you 
selected.

This is not as bad at it seems, however it is 
disconcerting. Please turn the page...

Form Design Tools ->Design->Views->View
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Set Form Control Properties

Find the Properties 
The following pages demonstrate how to correct 
the issue. These steps are worth reviewing. 
Please go to the Design View and find the 
Property Sheet.

Before You Begin: Change the View
Go to Home>Views->View.
Choose a View: Design View. 
The Form Design Tools should be available. 

3. Try it: Find the Property Sheet
Click once on the Rating Combo to select it.
Go to Form Design Tools ->Design->Tools.
Click on Property Sheet.

What Do You See? The Property Sheet should 
open on the right side of the database.

Keep going...

Form Design Tools ->Design->Tools->Property Sheet

Comma Training Page 50

Microsoft Access 2013 Inermediate   Page 50 of 281



Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Set Form Control Properties

Edit the Properties 
This Combo Box has tblRating as the Record 
Source. tblRating has two Fields:
RatingID, (Number)
Rating, (Text)

The Movies Form has tblMovies as the Record 
Source. tblMovies has many Fields, including:
Rating, (Text)

Before You Begin: What Do You See?
The Control Source is Rating, which is Text. 
The Column Count is 2.

4. Try it: Edit the Properties
Name: RatingCombo
Column Widths: 0", 1"

Now, the first Column will be hidden ( 0" wide) and 
the second Column will show the Rating.
Keep going...

Memo to Self: The Combo Box shown on this 
page is Named Combo17. The name on your 
Combo Box may be Combo1, 2 or whatever the 
auto number may be.  

Form Design Tools ->Design->Tools->Property Sheet
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Use the Combo Box
Before You Begin: Change the View
Go to Form Design Tools ->Design->Views.
Choose a View: Form View. 

5. Try it: Test the Combo Box Control
The Movie Form is open in Form View.
Select a Rating: R

What Do You See? Do you see one Column or 
two? When you select a value from the list does 
the Combo store the Text or a Number?

Summary 
The Movie Form uses a Combo Box now to look 
up a value in the Rating Table and store that value 
in the Movie Table. 

This is an example of one-from-many.
Each movie has only one Rating. The Combo Box 
lets the User select one Rating from a Table that 
has many Ratings, tblRating.

That was a good start. Go get a cookie and meet 
me for the next lesson.
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Lesson 1: One-to-Many
Try This: Do the following steps
1. Open the Brown Bag Lunch database you have been working on. Or, you may 
download BBL Int ver2.accdb
2. Create a new Table with the command Create->Tables->Table Design.
3. Add the following Fields and Data Types:
TypeID, AutoNumber (Also make this the Primary Key)
Type, Text
4. Save the Table as tblType.
5. Go to Datasheet View.
6. Add the following to the Type column:
Sandwich, Snacks, Breakfast, Tray, Beverages
7. Open the Form Products and switch to Design View.
8. Delete the Type Box on the Form.
9. Go to Form Design Tools->Design and select a Control: Combo Box.
Add the Combo Box to the form where the Label Type used to be.
10. Choose the option to get the Combo Box values from another source. 
Select tblType as the source. Select all available fields.
11. Select the Field Type to sort Ascending.
12. Do NOT hide the Key column. Instead, resize the TypeID column to width zero.
13. Select a field to store: choose Type. Store the value in field Type.
14. Name the Combo Box: Type and finish the Wizard.
15. Change to Form View. Test the Combo Box. Does it display five types of products?
16. Return to Design View. Select the Type Combo Box and open the Property Sheet.
17. Change the Combo Box name to TypeCombo. 
Set the column widths to be 0”, 1.25”
18. Save the Form. Close the database.

Practice Activities

Comma Training Page 53

Microsoft Access 2013 Inermediate   Page 53 of 281



1. Which of the following can look up data 
from one table and add it to another?
A. Select Query
B. Combo Box
C. Table Design
D. Label
Tip: Intermediate Access, page 36

2. What are the options for getting the target 
data for a combo box? 
(Give all correct answers.)
A. From another Table
B. From another Query
C. Type the values I want (in a new list)
D. Find a record on my Form from the values 
I select.
Tip: Intermediate Access, page 38

3. Which step of the combo box Wizard 
prompts the user to enter a Label?
A. First step
B. Last step
C. The Wizard does not prompt for a label
D. The third step
Tip: Intermediate Access, page 47

4. Forms should be tested in Form view as a 
user sees them. 
A. True
B. False
Tip: Intermediate Access, page 48

5. Which of the following is true? 
(Give all correct answers.)
A. Hiding the key column removes that 
column from use, including matching the 
values to store
B. Setting the column width as 0” in the 
Property sheet hides the column from sight 
while still allowing the data to be used
C. Microsoft Access hides the Key Column 
by default
Tip: Intermediate Access, page 51

Test Yourself
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© 2014 Comma Productions, LLC

Access 2013: Representing One-to-Many

Intermediate Access Objectives
In this lesson, you will learn how to: 
1. Use a Query as the Record Source for a 
Subform.
2. Apply Quick Styles to Controls in a 
Form/Subform.
3. Apply Conditional Formatting to a Subform that 
has Datasheet as the Default View.
4. Create a Form that has a Bound Control, a 
Combo Box, that will filter the Records in the 
Subform.

Forms and Subform Design, Part 1
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1. Readings
Read Lesson 3 in the Intermediate Access 
guide, page 55-84.

Project
A Movie Search Form and Movie Subform.

Downloads
FrontRowVideo Int3.accdb
popcorn1.gif, popcorn2.gif, 
popcorn3.gif, popcorn4.gif, movies1.gif.

BBL Int ver3.accdb

2. Practice
Do the Practice Activity on page 85.

3. Assessment
Review the Test questions on page 86.

Menu Maps
From the Create Ribbon.
1. Create ->Queries ->Query Design, page 61
2. Create ->Forms->More Forms->Datasheet, page 64
6. Create ->Tables->Table Design, page 72

From the Form Tools->Datasheet Ribbon
3. Form Tools ->Datasheet, page 65
4. Datasheet->Formatting-> Alternate Row Color, page 66
5. Datasheet->Formatting-> Conditional Formatting, page 67

Create Ribbon

Form Tools->Datasheet Ribbon

Lesson 3 : Form and Subform Design, part 1
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Representing One-to-Many Relationships
In real life, one customer gets many movies. In Microsoft Access, a one-to-many relationship is created with a Form and a Subform. A 
Subform is a Form, usually in a Datasheet or List View, that is linked to the Parent Form.  These database designs will be taught in two 
lessons. In the first lesson we will create two new Forms: a MovieSearch Form and a MovieSearchSubform. Each Form will have a new 
Record Source. The previous lesson used a Combo Box to select one value from many. 

This lesson will use a Combo Box to filter the movies: There are many movies that have the same Rating. In the following lesson, we will 
link the Form and Subform. We will test the programming and troubleshoot the possible errors. 

Microsoft Office Access: Example of a Form with a Subform
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What is the Plan? 
There are two different Views that will be used in these 
new forms: Single Form and Datasheet.

The question is usually at the top of a Form. This is the 
Parent Form and the Default View will be Single Form. 
The answer is shown on the bottom as a list. This is the 
Subform and the Default View will be Datasheet. Here is 
the design plan. 

Create a Record Source for the Subform: 
The MovieSearchSQ query has one Table.

Create the Subform: MovieSearchSubform.
The MovieSearchSubform will be in Datasheet View.

Create a Record Source for the Parent Form: 
tblMovieSearch, a Table to hold the search criteria.

Create the Parent Form: MovieSearch
The MovieSearch Form will use a Combo Box to look up 
the Rating. It will be in Single Form View. 

That's the plan. Here are the steps.

Microsoft Office Access: Example of a Form with a Subform
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: View All Access Objects

Before You Begin 
Before You Begin: Open the Sample Database
Go to Start Microsoft Access.
Access will prompt you to open a database. 

This lesson uses the database that was developed in 
the previous lesson. You can continue with the same 
database if you wish. 

The  FrontRowVideo Int3.accdb database has:

Three Tables: tblCustomers, tblMovies, tblRating

Four Queries: MovieSQ, MoviesByYearSQ, 
CustomerNameSQ and CustomerHomePhoneSQ

Two Forms: Customers, Movies

Two Reports: Movies by Year, Customer Name

Keep going....

Memo to Self: Databases need to Read and Write. 
Click Enable Content if you see the Security Warning. 

Start -> Microsoft Access 2013
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: View All Access Objects

Review the Data 
A database is only as good as the data. What 
kind of data is in this database?

Try This: Review the Data
Go the All Access Objects.
Double-click a Table: tblMovies

What Do You See? There are 401 movies in 
tblMovies.

Try This, Too: Sort the Data
Select the Rating and Genre Columns.
Go to Table Tools->Sort & Filter.
Select: Ascending. 

What Do You See, Now? The movie records 
aren't complete. Some of the movies do not 
have a Rating, some do not have a Genre. 
Many are missing both. This will be part of our 
discussions, later.

OK! Save the Table
Go to File->Save.
Close the Table, too. 

Table Tools->Sort & Filter->Ascending
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.1 Create a Query: Select a Table

Create a Record Source 
for the Movie Subform 
The Subform will be a list of the movies. It will 
look like a Datasheet. The Record Source for 
this new Subform will be a Select Query that 
uses tblMovies. 

1. Try it: Create a Query
Go to Create ->Queries ->Query Design.

You will be prompted by the Show Table. 
Select a Table: tblMovies.

Click Add. 

Keep going...

Create ->Queries ->Query Design

Comma Training Page 61

Microsoft Access 2013 Inermediate   Page 61 of 281



Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.1 Create a Query: Add New Fields

Add Fields to the Query 
2. Try it: Add Fields to the Query
Add the following Fields to the QBE Grid:
MovieID
Movie
Rating
Genre

Do This, Now: Save the Query
Go to File->Save.
Enter the name: MovieSearchSQ.

Keep going...

File ->Save
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.1 Create a Query: Run a Query

Run the Query 
3. Try it: Run the Query
Go to Query Tools ->Design->Results.
Click on Run.

What Do You See? The MovieSearchSQ 
The Query returned 401 movies. 
There are four Fields:
MovieID
Movie
Rating
Genre

OK, the Query works. 
Now, let's build a Form with it. 

Do This, Now: Close the Query.

Query Tools ->Design->Results->Run
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.1 Create a Form: Create Forms With Application Parts (Datasheet)

Create the Movie Subform 
A Datasheet is a good way to list the movies in 
the Subform. Here are the steps. 

1. Try it: Create a Datasheet Form
Go to All Access Objects: Queries.
Select a Query: MovieSearchSQ.
(Click once to Select the Query. Do not double 
click or the Query will run)

Go to Create ->Forms->More Forms.
Click on Datasheet.

Keep going...

Create ->Forms->More Forms->Datasheet
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.1 Create a Form: Create Forms With Application Parts (Datasheet)

Hello, Movie Subform 
2. Try it: Review the Datasheet Ribbon
A new Datasheet Form should open. The 
Form Tools now has a Datasheet Ribbon.

The Datasheet Ribbon includes:
Views
Themes
Tools
Formatting

This could be fun. 
Keep going, please...

Form Tools ->Datasheet
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form: Modify Existing Forms (Datasheet)

Format the Rows 
3. Try it: Format the Rows
The Datasheet form is still open.
Go to Form Tools ->Datasheet->Formatting.
Click on Alternate Row Color.
Select a Color: White, Background1, Darker 15% 
(light grey).

What Do You See? Every other Row should be filled 
with the color you selected. Formatting the Rows in 
alternating colors should make them easier to read.

Keep going...

Form Tools ->Datasheet->Formatting-> Alternate Row Color
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form: Modify Existing Forms (Conditional Formatting)

Use Conditional Formatting 
Conditional Formatting formats the color 
depending on the Rules that you set up. This 
example will format the Rating data.

Before You Begin: Select the Rating Column 
in the Datasheet Form. Selecting the Column 
is important in this example.  

1. Try it: Use Conditional Formatting 
Go to Form Tools ->Datasheet.
Go to Formatting.
Click on Conditional Formatting.

The Conditional Formatting Rule Manager
should open. The Rating Column was selected 
so this formatting will be applied to the Rating 
data. 

Do This, Now: Create a New Rule
Click on New Rule. 

Keep going...

Form Tools ->Datasheet->Formatting-> Conditional Formatting

Comma Training Page 67

Microsoft Access 2013 Inermediate   Page 67 of 281



Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form: Modify Existing Forms (Conditional Formatting)

Edit the Formatting Rule 
Each Rating in the Rating Table can be 
assigned a different color. 

For example, G rated movies could be 
formatted green. R rated movies could be 
formatted red.

2. Try it: Edit the Formatting Rule
Field Value is: equal to
Enter the Rating: G
Format the color: green

Keep going...

Form Tools ->Datasheet->Formatting-> Conditional Formatting
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form: Modify Existing Forms (Conditional Formatting)

Add More Rules 
3. Try it: Add More Rules
Add a Rule for the PG Rating
Click on New Rule.
Field Value is: equal to
Enter the Rating: PG
Format the color: orange

Add a Rule for the R Rating
Click on New Rule.
Field Value is: equal to
Enter the Rating: R
Format the color: red

Show formatting rule for Rating:
There should be three rules.

Click OK. So...what do you see?

Form Tools ->Datasheet->Formatting-> Conditional Formatting
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form: Modify Existing Forms (Conditional Formatting)

Review the Formatting 
4. Try it: Review the Formatting
The Rating data has been formatted based on 
the Conditional Formatting Rules that you just 
programmed:
Green for G
Orange for PG
Red for R

What Else Do You See? The PG13, PG14 and 
PG15 Ratings were not formatted with a 
Conditional Formatting Rule. They are still the 
default Theme color, black.

Keep Looking: The Conditional Formatting also 
over-wrote the Table formatting for alternating 
colors on the Rows.

Made you look.

Form Tools ->Datasheet->Formatting-> Conditional Formatting
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Finish the Subform 
A Subform doesn't need many 
embellishments. It doesn't have a Form 
Header for logos or branding.

5. Do This, Now: Save the Subform
Go to File->Save.
Enter the Form Name: 
MovieSearchSubform.

Click OK and close the Subform.
Very Good.

File ->Save
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Exam 77-424: Microsoft Access 2013
2.0 Build Tables 
2.1 Create a Table: Create New Tables

Create a Record Source
for the Movie Search Form 
The Record Source for the new Movie Search 
Form will be a new Table, tblMovieSearch, which 
will have three Fields.

1. Try it: Create a Table
Go to Create ->Tables->Table Design.

Keep going...

Create ->Tables->Table Design
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Exam 77-424: Microsoft Access 2013
2.0 Build Tables 
2.4 Create and Modify Field: Add Fields to Tables

Edit the Fields 
2. Try it: Edit the Fields
Enter the following, please:

Field Name: MovieSearchID
Data Type: AutoNumber

Field Name: Rating
Data Type: Short Text

Field Name: Genre
Data Type: Short Text

Try This, Too: Create a Primary Key
Select a Field: MovieSearchID
Go to Table Tools ->Design->Tools.
Click on Primary Key.

What Do You See? The MovieSearchID Field 
has the symbol for the Key. In the Field 
Properties, the values are Indexed (yes), so 
that there will be no duplicates.

Keep going...!

Table Tools ->Design->Tools->Primary Key
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Exam 77-424: Microsoft Access 2013
2.0 Build Tables 
2.1 Create a Table: Save a Table

Save the MovieSearch Table 
3. Try it: Save the Table
Go to File ->Save.
Enter a name: tblMovieSearch.

Click OK. 

This little table will be the Record Source for 
the Master Form, the top part of the Movie 
Search Form.

The purpose of tblMovieSearch is to hold the 
Rating value that the user selects from the 
Combo Box. 

Close tblMovieSearch. 

Keep going...

File ->Save
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.1 Create a Form: Create New Forms

Create a Movie Search Form 
This Form will give the User a Combo Box to Filter 
the movies. For example, the Rating Combo Box 
could be used to show only G rated movies.

1. Try it: Create a New Form
Go to Create ->Forms->Form Design.

Try This, Too: View the Property Sheet
Go to Form Design Tools->Design->Tools.
Click on Property Sheet.

What Do You See? The Property Sheet should 
open on the left side of the screen.
The Selection type is Form.

What Else Do You See? The Record Source is 
blank. This Form is not connected to a Table or 
Query, yet. 

It is Unbound.

Keep going...

Create ->Forms->Form Design
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Modify Data Sources

Movie Form Design:
Select a Record Source 
When a Form has a Record Source then it is 
Bound. This Movie Search Form will use 
tblMovieSearch for the Record Source. 

2. Try it: Select a Record Source
The new Form is open in Design View and the 
Property Sheet is open. 

Go to Property Sheet->All.
Click on Record Source.
Select: tblMovieSearch.

Now, this Form is Bound to a Table.
The Fields in tblMovieSearch are available in 
the Field List if you click on Add Existing 
Fields. 

Keep going...

Form Design Tools->Design->Tools->Property Sheet
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form: insert Headers and Footers

Movie Form Design:
Add a Title to the Header 
The Header is a excellent place to confirm that 
this is the right Form. A little branding works, 
too. This step will add a Title to the Form 
Header.

3. Try it: Add a Title to the Header
The Form is still open in Design View. 
The Property Sheet is open. 

Go to Form Design Tools->Design.
Go to Header/Footer->Title.

What Do You See? A new Form Header will 
be added to this Form. There should be a new 
Label in the Header.

Edit the Label: Search the Movies 
Keep going...

Form Design Tools->Design->Header/Footer->Title
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Add Form Controls (Combo Box Wizard)

Movie Form Design:
Add a Combo Box
Controls can be Bound or Unbound as well. A Control 
is Bound if it has a Field in a Table or Query as a 
Record Source. 

The following pages will add a Rating Combo Box to 
this Form. This Combo Box will be used to filter the 
movies in the Subform. You'll see. It's cool. 

4. Try it: Add a Combo Box
The Form is still open in Design View. 
The Property Sheet is open. 

Go to Form Design Tools->Design->Controls.
Select a Control: Combo Box.

Click anywhere in the Detail section of the Form.
The Combo Box Wizard will open.

Keep going...

Form Design Tools->Design->Controls
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Add Form Controls (Combo Box Wizard)

Movie Form Design:
Combo Box Options
Here are the answers to the first steps in the 
Combo Box Wizard.

5. Try it: Walk through the Wizard
Get the values from a Table or Query

Go Next. Select a Record Source
Select a Table: tblRating

Go Next: Select the Fields
Select both available Fields:
RatingID (a number)
Rating (text)

Go Next: Sort the Fields
Select Rating to Sort (ascending)

Go Next. 

Keep going...

Form Design Tools->Design->Controls
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Add Form Controls (Combo Box Wizard)

Movie Form Design:
Combo Box Key Decision
6. Try it: Unhide the Key Column
Uncheck the option: Hide key column.

What Do You See? This Combo has two 
columns: RatingID and Rating.

Click Next. 

Memo to Self: This option lets you choose 
which Field should be stored. 

If the key column is hidden, the Combo Box 
Wizard will select the Primary Key, RatingID, 
by default.

Form Design Tools->Design->Controls

Comma Training Page 80

Microsoft Access 2013 Inermediate   Page 80 of 281



Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Add Form Controls (Combo Box Wizard)

Movie Form Design:
Save the Rating Data
The last two steps in the Combo Box Wizard 
prompt you to select the Field you wish to 
store in tblMovieSeach. 

7. Try it: Select the Rating Field
Select a Field: Rating
Click Next.

8. Try it: Store the Rating Field Data
Select a Field to Store: Rating
Click Next.

OK, Do This Now: Finish the Wizard
Enter the Label: Rating.
Click Finish. 

What Do You See? There should be a new 
Combo Box on this Form.

One more step...

Form Design Tools->Design->Controls
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Edit Form Control Properties

Movie Form Design:
Edit the Combo Box 
The Rating  Combo Box Control has two 
columns. The first Column is the RatingID, 
which the User does not need to see. You can 
edit the Column Width to be zero so that it is 
hidden. 

9. Try it: Edit the Combo Box Property
The Form is still open in Design View. 
The Property Sheet is open. 
Go to Property Sheet->All.
Edit the following:
Name: RatingCombo
Column Widths: 0";1"
List Width: 1"

Do This, Now; Save the Form
Go to File->Save.
Enter the Form Name: MovieSearch

OK, does it work?

Form Design Tools->Design->Tools->Property Sheet
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Test the Combo Box 
Before You Begin: Change the View
Go to Form Design Tools->Design->Views.
Select a View: Form View. 

Try it: Test the Rating Combo Box
There are two parts to the test:
Can you see the list of options?
Can you select an option from the list?

What Do You See? Does your Combo work?

Form Design Tools->Design->Views->View->Form View
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So Far, So Good... 
The objectives for this lesson were

Create a Record Source for the Subform: 
MovieSearchSQ.

Create a MovieSearchSubform that displays 
movies as a Datasheet.

Create a Record Source for the MovieSearch 
Form, tblMovieSearch, a simple Table to hold 
the search criteria.

Design a MovieSearch Form that uses a 
Combo Box to look up the Rating.

In the next lesson, we will link the Form and 
Subform together.

Grab a cookie and come back when you are 
ready!
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Lesson 3: Form and Subform Design, part 1
Try This: Do the following steps
1. Open the Brown Bag Lunch database you have been working on. Or, you may download BBL Int ver3.accdb. 
2. Create a new Query using the Create Queries->Query Design command. Use tblProducts as the record source.
3. Add the following fields to the QBE Grid: ProductID, Item, Type, Specialty
4. Save the Query as ProductSearchSQ. Run the Query to test it, then close the Query.
5. Under All Access Objects->Queries, select the Product SearchSQ Query . 
Go to Create->Forms->More Forms->Datasheet
6. Format the Datasheet with Alternate Row colors. Use a light color of your choice.
7. Apply Conditional Formatting to the Specialty column as follows:
Vegetarian has green text
Gluten Free has orange text
Low-Fat has pink text
8. Save the Form as ProductSearchSubform and close the form.
9. Create a new Table. Add the following Field and Data Types:
ProductSearchID, Autonumber (Also make this the Primary Key)
Type, Text
Specialty, Text
10. Save the Table as tblProductSearch. Close the Table
11. Create a new Form using the command Create->Forms->Form Design.
12. Using the Property Sheet, select the record source: tblProductSearch
13. Add a Header to the Form. Edit the Label to say: Search Products
14. Add a Combo Box to the detail section of the Form. Get the values from the Table tblType. 
Select both available Fields.
15. Uncheck the option to hide the Key column. Set the Field Type to be stored in the Type Field. Finish the Wizard.
16. Using the Property Sheet, rename the Combo Box as TypeCombobox. Set the column widths as 0”, 1”
17. Save the Form as Product Search
18. Save and close the database.

Practice Activity
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1. In Microsoft Access, a one-to-many 
relationship is created using which of the 
following?
A. A Table and a Form
B. A Form and a Subform
C. Form design and Table design
D. Macros and Forms
Tip: Intermediate Access, page 57

2. Which command formats text based on 
the rules you create?
A. Themes
B. Styles
C. Conditional Formatting
D. Design
Tip: Intermediate Access, page 67

3. Which of the following things are not parts of a 
Subform?
A. Form Header
B. Logos
C. Branding
D. Data
Tip: Intermediate Access, page 71

4. Which of the following is true about an Unbound 
Form?
A. The Form is not connected to a Table or Query
B. Once a record sourse is connected to the Form, it 
is considered Bound.
Tip: Intermediate Access, page 75, 76

5. If the Key column is hidden during the Combo 
Box Wizard, then Access will select the Primary Key 
(the ID field) by default for the field to store.
A. True
B. False
Tip: Intermediate Access, page 80

Test Yourself
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© 2013 Comma Productions, LLC

Access 2013: Representing One-to-Many

Intermediate Access Objectives
In this lesson, you will learn how to: 
1. Review the Properties for a Form: Record 
Source, Controls, View.
2. Use the Subform Wizard to add a Subform to a 
Form and link them by a common Field.
3. Create a Combo Box to filter the Records in the 
Subform.
4. Add a Macro to Refresh the Records in the 
Subform when the Combo Box is changed.

Forms and Subform Design, Part 2
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1. Readings
Read Lesson 4 in the Intermediate Access 
guide, page 87-114.

Project
Link a Form to a Subform and test it.

Downloads
FrontRowVideo Int4.accdb
popcorn1.gif, popcorn2.gif, 
popcorn3.gif, popcorn4.gif, 
movies1.gif.

BBL Int ver4.accdb

2. Practice
Do the Practice Activity on page 115.

3. Assessment
Review the Test questions on page 116.

Menu Maps
From the Home Ribbon
Home ->Views->View->Form Design, page 92
Home ->Records->Refresh, page 102

From the Form Design Tools->Design Ribbon
1. Form Design Tools->Design->Tools->Property Sheet, page 93
2. Form Design Tools->Controls->Subform/Subreport, page 96
3. Form Design Tools->Design->Views->View, page 101

From the Macro Ribbon
1. Macro Tools->Design, page 105

Form Design Tools->Design Ribbon

Form Design Tools->Design Ribbon

Lesson 4 : Forms and Subform Design, part 2
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Forms and Subform Design, part 1 defined the scope of the programming: We wanted to 
search the movies by Rating. This is a one-to-many relationship. Microsoft Access represents a 
one-to-many relationship with a Form and Subform. The Movie Search Form stores the Rating 
in a new table, tblMovieSearch. The Movie Search Subform lists the movies that match that 
criteria. It looks up the movies with a Select Query based on the movies Table: tblMovies. 

Forms and Subform Design, part 2  links the Form and Subform by a common Field: Rating. 
This lesson walks through the steps and offers some options for troubleshooting the 
programming. Let's get started.

Forms and Subform Design, Part 2

Access: Example of the completed 
Form and Subform
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What Are the Objectives? 
Both the Form and the Subform have a Rating 
Control, which is Text. First, we will confirm that both 
Forms have the same Field. Then, we'll use the 
Subform Wizard to walk through the steps.

Review the Form and Subform
Open both Forms in Design View
Identify the Record Source
Confirm the Default View

Use the Subform Wizard to Link the Forms
Select the Subform
Define the common Field: Rating

Review the Subform Properties 
Confirm the Master and Child Links
Test the Movie Search Form
Automate the Form with a bit of code (a Macro!)

Troubleshoot the Programming
Review the Form and Control Properties
Review the Master and Child Links 
Review the Embedded Macro

That's the plan. That's a lot...maybe not    ;-D 

Microsoft Access: Example of a Form Control with a Macro
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: View All Access Objects

Before You Begin 
Before You Begin: Open the Sample Database
Go to Start ->Microsoft Access.
Access will prompt you to open a database. 

This lesson uses the database that was programmed 
in the previous lesson. You can continue with the 
same database if you wish. 

The  FrontRowVideo Int4.accdb database has:
Four Tables: tblCustomers, tblMovies,  
tblMovieSearch and tblRating.

Five Queries: CustomerHomePhoneSQ, 
CustomerNameSQ, MoviesByYearSQ, MovieSQ, and 
MovieSearchSQ.

Four Forms: Customers, Movies, MovieSearch and 
MovieSearchSubform.

Two Reports: Movies by Year, Customer Name
Keep going...

Memo to Self: Click Enable Content if you see the 
Security Warning. 

Start -> Microsoft Access 
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form : Modify Existing Forms (Form Properties)

Open the MovieSearch Form 
Let's begin by reviewing the Form and Subform 
designs.

1. Try it: Open the MovieSearchForm
Go to All Access Objects->Forms.
Open a Form: MovieSearch.
Go to Home ->Views->View->Form Design.
The Form Design Tools should be available.

Try This, Too: Review the Form Properties
Go to Form Design Tools->Design->Tools.
Click on Property Sheet.

What Do You See? The Form is selected.
The Record Source is: tblMovieSearch.
Default View: Single Form.

Keep going...

Home ->Views->View->Form Design
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form : Modify Existing Forms (Control Properties)

Review the Combo Properties 
2. Try it: Review the Combo Properties
Select the Rating Combo.

What Do You See? The RatingCombo control is 
selected. The Properties include:
Name: RatingCombo
Control Source: Rating
Visible: Yes
Column Count: 2
Column Widths: 0"; 1"

That means there are 2 Columns in the Combo 
Box. The first Column, RatingID, is hidden 
because the width is 0". The second Column, 
Rating, has a width of 1".

Please Close the MovieSearch Form. 

Form Design Tools->Design->Tools->Property Sheet
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form : Modify Existing Forms (Form Properties)

Open the MovieSearch Subform 
In the previous lesson we worked with the 
MovieSearch Subform in Datasheet View. Let's 
open the MovieSearch Subform in Design View and 
look at the Properties.

3. Try it: Open the MovieSearchForm
Go to All Access Objects->Forms.
Open a Form: MovieSearchSubform.
Go to Home ->Views->View->Form Design.
The Form Design Tools should be available.

Try This, Too: Review the Form Properties
Go to Form Design Tools->Design->Tools.
Click on Property Sheet.

What Do You See? The Form is selected.
The Record Source is: MovieSearchSQ.
Default View: Datasheet.

Keep going...

Home ->Views->View->Form Design
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Modify Data Sources

Review the Record Source 
The MovieSearchSubform uses a Query to look up 
the answers. You can use the Property Sheet to 
open the Record Source if you wish.

4. Try it: Review the Record Source
The Form is Open in Design View.
The Property Sheet is available.

Click on the Record Source: MovieSearchSQ.
There should be a 3-Dot Builder button to the right 
of the Record Source.
Click on the 3-Dot Builder.

What Do You See? MovieSearchSQ should open in 
Design View. There are four Fields:
MovieID
Movie
Rating
Genre

Please Close the MovieSearchSQ Query. 
You should return to the MovieSearchSubfrom.
Please Close the MovieSearchSubform. 

Form Design Tools->Design->Tools->Property Sheet
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Add Form Controls (Subform/Subreport)

Add the Subform to a Form 
The Subform is ready to be added to the 
MovieSearch Form. First, you need to open the 
Master Form in Design View. Then you can add 
the Child Subform as a Control.

1. Try it: Open the Master Form
Go to All Access Objects->Forms.
Open a Form: MovieSearch..
Go to Home ->Views->View->Form Design.
The Form Design Tools should be available.

Try This, Too: Add a Subform
Go to Form Design Tools->Controls.
Click on Subform/Subreport.

What Do You See? Your mouse should have a 
little square symbol following the cursor.

Keep going...

Form Design Tools->Controls->Subform/Subreport
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Add Form Controls (Subform/Subreport)

The Subform Wizard
2. Try it: Select a Subform
The mouse should have a little symbol following the 
cursor after you click on Subform/Subreport.

Now, click in the Detail section of the MovieSearch 
Form. This should start the Subform Wizard.

What Do You See? The Subform Wizard will prompt 
you to select the data. You can choose an existing 
Table or Query. You can also select an existing Form.

Go to Use an existing form.
Select MovieSearchSubform.

Click Next. 

Keep going...

Form Design Tools->Controls->Subform/Subreport
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Add Form Controls (Subform/Subreport)

Subform: Select a Field 
The next step in the Subform Wizard asks you 
to choose which Field(s) will be used to link 
the Master Form to the Child, the Subform. 

The default option is: Choose from a list. 
The Computer Mama sez it is often easier to 
Define your own.

3. Try it: Select a Field
Select: Define my own.
Select a Form/report Field: Rating
Select a Subform/subreport Field: Rating.

Click Next. 

Keep going...

Memo to Self: Rating (Text) on the Master 
Form matches with Rating (Text) on the 
Subform.

Match, match, match. 

Form Design Tools->Controls->Subform/Subreport
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Add Form Controls (Subform/Subreport)

Finish the Subform Wizard 
4. Try it: Name the Subform
Enter the Subform Name: 
MovieSearchSubform.

Click Finish to close the Subform Wizard.

So...what do you see? 

Keep going...!

Form Design Tools->Controls->Subform/Subreport

Comma Training Page 99

Microsoft Access 2013 Inermediate   Page 99 of 281



Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form : Modify Existing Forms (Form Properties)

Hello, Subform! 
There should be a new Subform in the Detail section 
of the MovieSearch Form. Each option that you 
selected with the Subform Wizard is saved in the 
Property Sheet. 

1. Try it: Review the Subform Properties
Select the Subform: there should be a yellow border 
around the Subform when it is selected.

Go to Property Sheet->All.

What Do You See? The Subform is selected.
The Name is: MovieSearchSubform.

Link Master Fields: Rating
Link Child Fields: Rating

Try This, Too: Edit the Subform Properties Edit 
the Height: 4"

Well, does it work? Let's go see...

Form Design Tools->Design
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form : Modify Existing Forms (Form View)

Test the New Subform 
There's only one way to find out if a Form works: go 
to Form View and act like a User.

2. Try it: Test the New Subform
Go to Form Design Tools->Design->Views.
Select a View: Form View.

What Do You See? The Rating Combo has PG. 
The Subform shows 71 movies in this database that 
match the PG Rating.

What Else Do You See? The values in the Rating 
Column have Conditional Formatting. The PG 
Rating is formatted orange.

Keep going...

What If It Doesn't Work? Sometimes the 
MovieSearch Form doesn't show anything when you 
go to Form View. 

Please try this: Refresh the Records
Go to Home->Records->Refresh.
Did that work? 
We'll address this issue on the next page.

Form Design Tools->Design->Views->View
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Test the Rating Combo 
The purpose of having the Rating Combo is to 
filter the movie list in the Subform to find the 
movies that match.

3. Try it: Select a Different Rating
Select a Rating: R

What Do You See? The Subform did NOT 
update automatically to match the criteria in 
the Rating Combo. You can Refresh the 
Records manually (by hand) to see if the Form 
and Subform work together. 

Try This, Too: Refresh the Records
Go to Home->Records>Refresh.

Now, What Do You See? The movies listed in 
the Subform match the R Rating on the Master 
Form. Keep going...

Home ->Records->Refresh
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form : Modify Existing Forms (Control Properties)

Automate the Process 
Users would not be happy if they had to click on 
Refresh each time they select something from the 
Rating Combo. Fortunately, all of the Access 
Objects can be programmed (some assembly 
required). You can add a little bit of Code to make 
the Subform Refresh automatically. These are 
called Events.

4. Try it: Find the Event Properties
Go to Home ->Views->View->Form Design.
The Form Design Tools should be available.

Select the Rating Combo.
Go to Property Sheet->Event.

What Do You See? There are several options for 
what happens when a User clicks. The Events can 
occur On Click or On Double (Dbl) Click. Events 
can also be programmed to run Before or After a 
Control is Updated.

What Makes Sense? In this example, the 
Subform should Refresh After Update (not 
before!)  

Keep going...

Home ->Views->View->Form Design
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form : Modify Existing Forms (Create an Event)

Create an Event 
There are three ways to program an Event: Macro 
Builder, Expression Builder, and Code Builder, 
which is Visual Basic for Applications.

This first example will be a simple Macro with one 
line of Code: Refresh.

5. Try it: Create a Event
The MovieSearch Form is in Design View and the 
Rating Combo is selected.

Go to Property Sheet->Event.
Click on After Update.
Click on the 3-Dot Builder.

You will be prompted to choose a builder:
Select: Macro Builder.

Keep going...

Form Design Tools->Design->Tools->Property Sheet
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form : Modify Existing Forms (Create an Event)

Hello, Mighty Macros!
Yes, you may have heard programmers speak about 
Macros. Macros can record the steps that a User 
does again and again and automate the process. 

6. Try it: Add an Action
Go to the blank Action (the green plus sign)
Select an Action: Refresh.

Try This, Too: Save the Macro
Go to Macro Tools->Design->Save.

And Do This: Close the Macro Builder
Go to Macro Tools->Design->Close->Close.

Keep going...

Macro Tools->Design
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form : Modify Existing Forms (Create an Event)

Back at the Ranch 
7. Try it: Review the Properties
The MovieSearch Form is in Design View and 
the Rating Combo is selected.

Go to Property Sheet->Event.

What Do You See? There is a After Update 
Event for the Rating Combo. 
It is an Embedded Macro. 

Now, does it work? 

Keep going...!

Form Design Tools->Design->Tools->Property Sheet
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form : Modify Existing Forms (Create an Event)

Test the Macro 
Before You Begin: Change the View
Go to Form Design Tools->Design->Views. 
Select a View: Form View.

8. Try it: Test the Event
Select a Rating: G

What Do You See? Did the Form work? Did the 
MovieSeachSubform automatically Refresh the 
Records and display the movies that match the 
Rating Combo?

Made You Smile: It's fun when it works.

Form Design Tools->Design->Views->View
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form : Modify Existing Forms (Form Properties)

What If It Doesn't Work? 
Everything is fun and the sky is blue when the 
programming works. What if it doesn't work? What 
steps should you take to troubleshoot the Form and 
Subform?

1. Try This: Open the Form in Design View
Open a Form: MovieSearch.
Go to Home ->Views->View->Form Design

Try This, Too: Review the Form Properties
Go to Property Sheet: All.

Record Source: tblMovieSearch.
Default View: Single Form.

Do your Form Properties match this one?

Keep going...

Home ->Views->View->Form Design
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form : Modify Existing Forms (Control Properties)

Review the Combo Box 
There are several places to look when you 
troubleshoot the Combo Box. 

What Works, What Doesn't:
Can you see the Rating data?
Can you select a Rating from the list?
Does the Subform display the movies that match the 
Rating in the Combo Box?

2. Try it: Review the Combo Box Properties
Select the Combo Box.
Go to Property Sheet: All.

Control Source: Rating
Column Count: 2
Column Widths: 0";1"

Where Column 1 (hidden) is RatingID.
and Column 2 is Rating. 

Do your Control Properties match this one?

Keep going...

Form Design Tools->Design->Tools->Property Sheet
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form : Modify Existing Forms (Subform Properties-Links)

Review the Subform Links 
The previous pages looked at the Form and 
Subform Properties. We also reviewed the 
Properties for the Combo Box.

Even if both Forms are designed correctly, 
nothing will happen if the Form and Subform 
are not linked. There has to be a relationship 
between the Master and Child.

3. Try it: Review the Master and Child
The MovieSearch Form is open in Design 
View. The Property Sheet is available.

Select the Subform. There should be a yellow 
border around the Subform.

Go to Property Sheet: All.

Link Master Field: Rating.
Link Child Field: Rating.

Match, Match, Match. The Combo Box stores 
(Saves) the Rating as Text.

Form Design Tools->Design->Tools->Property Sheet
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form : Modify Existing Forms (Event Properties)

Review the Refresh Code
If everything is programmed correctly but the 
Subform will not update automatically, then 
you need to review the Macro. 

4. Try it: Review the Macro
The MovieSearch Form is open in Design 
View. The Property Sheet is available.

Select the Rating Combo.
Go to Property Sheet: Event.
There should be an Embedded Macro on the 
After Update Event.

Try This, Too: View the Macro Code.
Click on Embedded Macro.
Click on the 3-Dot Builder.

What Do You See? The Rating Combo: 
AfterUpdate Macro should open. 
There is one Command: Refresh.

Does your Macro look like this one?

Click Close.

Form Design Tools->Design->Tools->Property Sheet
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Finishing the Form 
Functionality, first...then Formatting. If the Movie 
Search Form works, then finish the Form with the 
following options. 

Before You Begin: The MovieSearch Form is open 
in Design View.

Try it: Add an Image to the Header
Go to Form Design Tools->Design->Controls.
Click on Image.
Browse to the Documents Folder. 
Select an image: popcorn1.gif

Try This, Too: Format the Header
Select a Fill Color: White.

Do This, Now: Save the Form.
Go to File->Save.

Alllllmost done...

Form Design Tools->Design->Controls->Image
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What Does the Form Look Like? 
Try This: View the Movie Search Form
Go to Form Design Tools->Design->Views.
Select a View: Form View.

The purpose of this Form is to filter the movie list by 
Rating. There are many Movies in the database that 
have the same Rating. 

Microsoft Access represents a one-to-many 
relationship (one Rating, many Movies) with a Form 
and Subform.

The key to making the Forms and Controls work is 
reviewing the Properties.

Form Design Tools->Design->Views->View
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Summary 
We began by reviewing the Properties for both 
Forms: the Record Source, Default View and 
Controls. Both Forms have a Rating Control, 
which is Text.

The Subform was added to the Form as a Control. 
The Forms were Linked, Master and Child, by a 
common Field: Rating. 

We added an AfterUpdate Event to make the 
Forms Refresh automatically when a User selects 
a Rating from the Combo Box.  

We used the Properties to troubleshoot the Form 
as well. 

Allez, Allez in Free. Time to go home. 
You done good. Go get two cookies.
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Lesson 4: Form and Subform Design, part 2
Try This: Do the following steps
1. Open the Brown Bag Lunch database you have been working on. 
Or, you may download BBL Int ver4.accdb. 
2. Open the Form Product Search and go to Design View.
3. Add a Subform to the Detail section. 
Use the command: Form Design Tools->Design->Controls-> Subform/Subreport.
4. Select the ProductSearchSubform when prompted.
5. Select the option “Define my Own” for linking Master and Child Forms. 
Choose the Form Field: Type and the Subform Field: Type
6. Name the Subform: Product Search Subform
7. Finish the Wizard. Go to Form View and test the Form. Do you see the Subform?
8. Go to Design View. Select the Type Combo Box and open the Property Sheet.
9. Edit the Event: After Update. Use the Macro Builder.
10. In the Macro Builder, add the Action: Refresh. Save the Macro and close the Builder.
11. Go to Form View & test the Form. Change the Type and check that the Subform refreshes.
12. Add the image Brown Bag Logo to the Header.
13. Save the Form. Save and close the database.

Practice Activities
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1. Which of the following is true about creating a 
Form and Subform? 
(Give all correct answers.)
A. The Master Form must be opened first before 
adding a Subform to it.
B. A Parent Form is the same as a Master Form
C. A Child Form is the same as a Subform
Tip: Intermediate Access, page 96

2. What is the command for creating a Subform 
on a Master Form?
A. Form Design Tools -> Controls-> Subform/ 
Subreport
B. Form Controls-> Add Subform
C. Form Design Tools-> Tools-> Subform 
Control
Tip: Intermediate Access, page 96

3. Which of the following is true about selecting 
fields that link the Master and SubForms? 
(Give all correct answers.)
A. You can pick the fields from a list
B. You can define your own fields 
C. You must make sure that the fields match
Tip: Intermediate Access, page 98

4. By default, a Subform updates automatically 
when the criteria in the combo box changes.
A. True
B. False
Tip: Intermediate Access, page 102

5. Which of the following are ways to program an 
Event? (Give all correct answers.)
A. Macro Builder
B. Event Builder
C. Expression Builder
D. Code Builder
Tip: Intermediate Access, page 104

Test Yourself
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© 2014 Comma Productions, LLC

Intermediate Access Objectives
In this lesson, you will learn how to: 
1. Create a Select Query to filter the 
Records in the Subform.
2. Use the Expression Builder to write the 
criteria that looks up the data on a Form 
and synchronizes the two Combo Boxes.
3. Use the Combo Wizard to add a Drop 
Down Control based on the Select Query.
4. Add an Event Procedure in Visual 
Basic to Refresh the Records in the 
Subform when the Combo Box is 
changed.

Access 2013: Representing One-to-Many

Forms and Subform Design, Part 3
Synchronized Combo Boxes
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1. Readings
Read Lesson 5 in the Intermediate Access 
guide, page 117-150.

Project
A Select Query that synchronizes two 
Combo Boxes and filters the Subform.

Downloads
FrontRowVideo Int5.accdb
BBL Int ver5.accdb

2. Practice
Do the Practice Activity on page 151.

3. Assessment
Review the Test questions on page 152.

Menu Maps
From the Form Design Tools->Design Ribbon
1. Design->Tools->Property Sheet, page 124
2. Design->Tools->Add Existing Fields, page 125
6. Design->Controls->Combo Box, page 137
7. Design->Tools->Property Sheet->Link Master Fields, 
page143

From the Query Design Tools ->Design Ribbon
3. Design->Query Set Up->Show Table, page 128
4. Design->Show/Hide->Totals, page 131
5. Design->Query Setup->Builder, page 133

Form Design Tools->Design Ribbon

Query Design Tools ->Design Ribbon

Lesson 5 : Synchronized Combo Boxes
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Microsoft Access: Example of a Form with two, synchronized Combo Boxes

Say someone wanted to lookup only PG13 rated movies. The Rating Combo Box that we programmed filters 
the MovieSearchSubform and displays all of the PG13 movies. You can add a second Combo Box that only 
shows the Genres for PG13 Movies. The Genre Combo would look up the Rating, PG13, and display all of the 
comedies that have a PG13 Rating. The two Combo Boxes are said to be synchronized because the first 
Combo Box sets the criteria for the second. This lesson creates the Genre Combo Box and programs it to look 
up the Rating on the Movie Search Form. 

Synchronized Combo Boxes
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What Are the Objectives? 
The Movie Search Form and Subform have a Rating 
Control, which is Text. This lesson will add the 
Genre Control. First, we will confirm that both Forms 
have the same Field. Then, we'll use a Query to look 
up the Rating and synchronize the Rating and 
Genre Combo Boxes.

Create a Genre Table
Add data to the Genre Table

Edit the Form and Subform
Add the Genre Control to the Master Form

Use the Property Sheet to Link the Forms
Confirm the Master and Child Links
Test the Movie Search Form
Automate the Form with a bit of code (a Macro!)

Troubleshoot the Programming
Review the Form and Control Properties
Review the Master and Child Links 
Review the Embedded Macro

That's the plan. 

Microsoft Access: Example of a Query in Design View
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: View All Access Objects

Before You Begin 
Before You Begin: Open the Sample Database
Go to Start ->Microsoft Access.
Access will prompt you to open a database.

This lesson uses the database that was programmed 
in the previous lesson. You can continue with the 
same database if you wish. 

The FrontRowVideo Int5.accdb database has:
Four Tables: tblCustomers, tblMovies, tblMovieSearch 
and tblRating.

Five Queries: CustomerHomePhoneSQ, 
CustomerNameSQ, MoviesByYearSQ, MovieSQ, and 
MovieSearchSQ.

Four Forms: Customers, Movies, MovieSearch and 
MovieSearchSubform.

Two Reports: Movies by Year, Customer Name.

Keep going...

Memo to Self: Click Enable Content if you see the 
Security Warning. 

Start ->Microsoft Access

Comma Training Page 121

Microsoft Access 2013 Inermediate   Page 121 of 281



Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.2 Manage Relationships and Keys: Set Primary Key Fields

Create the Genre Table 
In the beginning of this book we created a 
Rating Table to add Rating data to the Movie 
Table. In this lesson, we will create the Genre 
Table and use it to filter data in the Movie 
Table.

1. Try it: Create a New Table
The Database is open. 
Go to Create ->Tables->Table Design.
Enter a Field Name: GenreID.
Data Type: AutoNumber.

GenreID is still selected.
Go to Table Tools->Design->Tools.
Click on Primary Key. 

Enter a Field Name: Genre.
Data Type: Short Text.

Do This, Now: Save the Table
Go to File->Save.
Enter a Table Name: tblGenre
Click OK. 
So far, so good. 

Keep going...

Create ->Tables->Table Design
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Exam 77-424: Microsoft Access 2013
2.0 Build Tables 
2.3 Manage Records: Add New Records

Add Data to the New Table 
Before You Begin: Change the View
Go to Home->Views->View.
Select a View: Datasheet View.

2. Try it: Enter the Data
Add the following Genres:
Action
Comedy
Disaster
Documentary
Drama
Family
Horror
Musical
Mystery
Rock Musical
Romance
Satire 
Science Fiction
Thriller
Western

What Did You See? The GenreID is an 
AutoNumber. It incremented automatically.

Good. Close tblGenre. 

Keep going...

Home->Views->View->Datasheet View
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Modify Data Sources (Form Properties)

Edit the MovieSearch Form 
Let's review the MovieSearch Form Properties. Do 
we have what we need to add a Combo Box that 
looks up the Genre?

1. Try it: Open the MovieSearchForm
Go to All Access Objects->Forms.
Open a Form: MovieSearch.
Go to Home ->Views->View->Design View.
The Form Design Tools should be available.

Try This, Too: Review the Form Properties
Go to Form Design Tools->Design->Tools.
Click on Property Sheet.

What Do You See? The Form is selected.
The Record Source is: tblMovieSearch.

Keep going...

Form Design Tools->Design->Tools->Property Sheet
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form: Modify Existing Forms (Design View)

Review the Field List 
This movie search Form uses tblMovieSearch. 
What Fields are available in that Table?

2. Try This: Review the Field List
Go to Form Design Tools->Design->Tools.
Click on Add Existing Fields.

What Do You See? The Field List should open on 
the right side of the database. This list shows all of 
the Fields in the Record Source: tblMovieSearch.

Yes, there is a Field for Genre. Keep going...

Memo to Self: Tables and Forms cannot be 
opened in Design View at the same time: They are 
mutually exclusive. If you want to see the 
MovieSearch Form design, close the MovieSearch 
Table. If you want to review the Table, close the 
Form. 

Form Design Tools->Design->Tools->Add Existing Fields

Comma Training Page 125

Microsoft Access 2013 Inermediate   Page 125 of 281



Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Remove Form Controls

Add an Existing Field 
What happens if you drag an Existing Field to the 
a Form? Let's try it.

3. Try it: Add an Existing Field
Go to the Form Field List.
Drag the Genre Field to the Form, next to the 
Rating Combo Box.

What Do You See? The Genre Control is a Text 
Box by default. Our goal is to create a Combo 
Box.

Try This, Too: Delete the Genre Control
Select a Control: Genre.
Delete it and Save your changes. 

Close the MovieSearch Form. 

Form Design Tools->Design->Tools->Add Existing Fields

Comma Training Page 126

Microsoft Access 2013 Inermediate   Page 126 of 281



Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.1 Create a Query: Create Multi-Table Queries

Synchronized Combos
The Genre Combo will be based on a new Select 
Query that uses three Tables. This Query will also 
use the Group By option. 

Our Query will look up the Rating that the User 
selected on the Movie Form with the Rating 
Combo Box. We will create this code with the 
Expression Builder. 

Before You Begin: Close all of the Tables, Forms 
or Queries.

1. Try it: Create a Select Query
Go to Create ->Queries-> Query Design.

What Do You See? A blank query will open. The 
Show Table window will prompt you to choose a 
Table or Query.
Select a Table: tblMovies. Click Add.
Select a second Table: tblRating. Click Add.
Select a third Table: tblGenre. Click Add.
Click Close. 

Keep going...

Create->Queries->Query Design
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.2 Manage Relationships and Keys: Edit References Between Tables

Join the Tables 
When you join Tables you create a relationship 
between one table and another. The join is created by 
matching Fields with the same Data Type: Text with 
Text, or Numbers with Numbers. 

In this example, we will join tblMovies to the Genre 
and the Rating. 

2. Try it: Join the Tables
Select a Field from tblMovies: Rating.
Drag that Field to the Rating Field in tblRating.

What Do You See? The Join is represented by a 
black line from Rating in tblMovies to Rating in 
tblRating.

Try This, Too: Join the Tables
Select a Field from tblMovies: Genre.
Drag that Field to the Genre Field in tblGenre.

What Do You See, Now? There should be another 
Join from Genre in tblMovies to Genre in tblGenre.

Keep going...

Query Design Tools ->Design
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.2 Modify a Query: Add New Fields

Add Fields to the Query
3. Try it: Add Fields to the Query
Double click to add the following Fields:
From tblGenre: Genre.
From tblRating: Rating.
From tblMovies: Movie.

Sort the Genre: Ascending. 

Do This, Too: Save the Query
Go to File->Save.
Enter the Query Name: RatingSearchSQ.

RatingSearch because we are looking for 
the Rating that was selected on the Search 
Form. SQ because this is a Select Query.

Click OK. 

Keep going... 

Query Design Tools ->Design
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.1 Create a Query: Run Queries

Run the Query 
4. Try it: Run the Query
Go to Query Tools ->Design->Results->Run.

What Do You See? How many records do you see? 
There are 401 movies in tblMovies. This is a many-
to-many relationship. Many movies have a PG13 
Rating. Many comedies are PG13.

What Else Do You See? The RatingSearchSQ 
Query also returned many movies that did not have 
a Rating. 

What Do You Think? The purpose of this Select 
Query is to create a little list of Genres in a Combo 
Box. Right now, this Combo Box would show lots of 
repeats: many G, PG, PG13, R's on the drop down 
list.

In the following pages we will combine the Ratings 
with Totals so that the Combo Box will show only 
one G, one PG, etc on the drop down list. We will 
also filter out movies that don't have a Rating. 

So, let's keep going...

Query Design Tools ->Design->Results->Run
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.3 Utilize Calculated Fields and Grouping Within a Query: Group and Summarize Data

Group By Totals
This option will combine the repeated Ratings.

Before You Begin: Return to Design View.
Go to Home->Views->View->Design View.

Still Before You Begin: Edit the Query
Delete the Movie Field. 
There will be only two fields: Genre and Rating.

5. Try it: Edit the Select Query
Go to Query Tools ->Design->Show/Hide.
Click on Totals.

What Do You See? When you click on Totals the 
Query grid will show the Total Row. 
The default is Group By.

Try This, Too: Add Criteria
Type the Rating Criteria: Is Not Null.
Type the Genre Criteria: Is Not Null.

This will return the movies that do have (Is Not Null) 
a Rating or Genre in tblMovies. 

Keep going...

Query Tools ->Design->Show/Hide->Totals
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.1 Create a Query: Run Queries

Run the Query, Again 
6. Try it: Run the Query
Go to Query Tools ->Design->Results->Run.

What Do You See? How many records do you see? 
Now, there are 37 Records, not 401. Each Genre 
has Ratings. There are no duplicates.

Try This, Too: Return to Design View.
Go to Home->Views->View->Design View.

Keep going...

Query Design Tools ->Design->Results->Run
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.3 Utilize Calculated Fields and Grouping Within a Query: Add Calculated Fields

Link the Query to the Form 
A Query can look up a Field on a Form and use that 
data to select records that match. 

We'll use the Expression Builder to select the 
Rating on the MovieSearchForm and add it to the 
Rating Criteria in RatingSearchSQ. 

7. Try it: Find the Expression Builder
RatingSearchSQ is open in Design View.
Go to the Rating Field.
Delete the Criteria: Is Not Null.
Right-click the Criteria.
Select an Option: Build.
Keep going...

Query Design Tools ->Design->Query Setup->Builder
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.3 Utilize Calculated Fields and Grouping within a Query: Add Calculated Fields (Expression Builder)

Hello, Expression Builder 
8. Try it: Review the Expression Builder
At the top of the Expression Builder is the box where 
the code will be written.

The Expression Builder also has three columns:
Expression Elements
Expression Categories
Expression Values.

What Do You See? Look in the Expression Elements. 
RatingSearchSQ is selected. 

There are two Expression Categories: Rating and 
Genre. These are the two Fields in the 
RatingSearchSQ Query.

Keep going...

Query Design Tools ->Design->Query Setup->Builder
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.3 Utilize Calculated Fields and Grouping Within a Query: Add Calculated Fields (Expression Builder)

Use the Expression Builder 
9. Try it: Select an Expression Category
Go to the Expression Elements.
Double Click the database: FrontRowVideo Int4.accb.
Double Click: Forms.
Double Click: All Forms. 
Select a Form: MovieSearch.

What Do You See? The Expression Categories list all of 
the Fields that are available on the MovieSearch Form 
including the Popcorn Logo.

Try This, Too: Select an Expression Category
Double Click: RatingCombo.

Now, What Do You See? The Expression Builder will write 
the qualified name:
Forms![MovieSearch]![RatingCombo] 

Where Forms is the Access Object,
[MovieSearch] is the name of the Form,
[RatingCombo] is the name of the Control. 

Click OK to close the Expression Builder and return to the 
RatingSearchSQ Query. 
Keep going...

Query Design Tools ->Design->Query Setup->Builder
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.3 Utilize Calculated Fields and Grouping Within a Query: Add Calculated Fields (Expression Builder)

Review the Expression 
The Expression in the Rating Criteria looks up 
the RatingCombo on the MovieSearch Form. 
This is the Select Query we will use for the 
Genre Combo Box.

Do This: Save and Close the Query
Go to File->Save.
Close the Query. 

Go on to the next step in the programming: 
create the Combo Box. 

Query Design Tools ->Design
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Add Form Controls (Combo Box Wizard)

Create the Genre Combo 
The following pages will walk through the Combo 
Wizard and review the choices.

Before You Begin: Open a Form
Go to All Access Objects.
Select a Form: MovieSearch
Go to Home->Views-View->Design View. 

1. Try it: Create a Combo Box Control
Go to Form Design Tools->Design->Controls.
Click once on Combo Box.
Then click on the Detail section of the 
MovieSearch Form by the Rating Combo Box. 
The Combo Box Wizard should begin. 

Try This, Now: Choose a Method
Select: I want the combo box to get the values 
from another table or query.

Click Next. 

Keep going...

Form Design Tools->Design->Controls->Combo Box
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Add Form Controls (Combo Box Wizard)

Combo Box Wizard: 
Select a Query 
The Combo Box Wizard can look up the data from 
either a Table or a Query. The default view is 
Tables so you have to change it to Queries, first.

2. Try it: Select a Query
Click on Queries.
Select a Query: RatingSearchSQ.

Click Next. 

Keep going...

Form Design Tools->Design->Controls->Combo Box
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Add Form Controls (Combo Box Wizard)

Combo Box Wizard: Fields 
3. Try it: Select the Fields
There are two Fields in tblGenre:
Genre (text)
Rating (text)

Use the arrow to select a Field: Genre.

Click Next. 

Try This, Too: Edit the Sorting
Select a Field to Sort: Genre.  

Click Next, again. 

Keep going...

Form Design Tools->Design->Controls->Combo Box
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Add Form Controls (Combo Box Wizard)

Combo Box Wizard: #Name?
4. Try it: Preview the Drop Down List
This step in the Combo Box Wizard shows a 
preview of the data as it would appear in the drop 
down list. In the example on this page, the preview 
shows only #Name?.

#Name? means Access cannot find the data. The 
RatingSearchSQ looks up the data in the 
MovieSearch Form. That form has to be in Design 
View while we work on the Rating Combo. 

The data will be available when the Form is in 
Form View.

Click Next. 

Keep going...!

As Goofy always said in the cartoons:
"Somthin wrong here?"

Form Design Tools->Design->Controls->Combo Box
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Add Form Controls (Combo Box Wizard)

Combo Box Wizard: 
Save the Genre Data 
5. Try it: Store That Value
Store that value in this field: Genre.
Click Next. 

Do This, Too: Enter the Label
Type the Label: Genre.

Click Finish. 

Form Design Tools->Design->Controls->Combo Box
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Modify Form Controls (Form Properties)

Review the Properties 
6. Try it: Review the  Properties
Select the Genre Combo Box.
Go to Form Design Tools->Design->Tools.
Click on Property Sheet.

Try This, Too: Edit the Properties
Enter the Name: GenreCombo

What Do You See? The Properties include:
Control Source: Genre
Column Count: 1
Column Widths: 1"

That should work. This is a good time to save.

Do This, Now: Save Your Programming
Go to File->Save.

Form Design Tools->Design->Tools->Property Sheet
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Modify Form Properties (Link Form and Subform Form)

Link the Form and Subform 
The MovieSearch Form is already linked to the 
Subform by Rating. Now, we need to link the Forms 
by Genre as well. Here are the steps.

1. Try it: Select the Subform
Select the Subform. There should be a yellow border 
around it and the Property Sheet should indicate that 
a Subform/Subreport is selected. 

Try This, Too: Review the Subform Properties
The Subform Properties include:
Name: MovieSearchSubform
Link Master Fields: Rating.
Link Child Fields: Rating.

Click on Rating. The 3-dot Builder should be 
available, now.

Click on the 3-dot Builder. 

Keep going...

Form Design Tools->Design->Tools->Property Sheet
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Modify Form Properties (Link Form and Subform Form)

Use the Subform Field Linker 
2. Try it: Add Another Field
Select another Master Field: Genre
Select another Child Field: Genre

What Do You See? The Form and Subform are 
linked by two text Fields:
Rating matches Rating
Genre matches Genre

Click OK. 

Keep going...

Form Design Tools->Design->Tools->Property Sheet
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Modify Form Properties (Link Form and Subform Form)

Master and Child Links
3. Try it: Review the Links
The MovieSearchSubform is still selected. 
Review the Properties:
Link Master Fields: Rating;Genre
Link Child Fields: Rating;Genre

There are two Fields that Link the Master and the 
Child Forms. 

Keep going...

Form Design Tools->Design->Tools->Property Sheet
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form: Modify Existing Forms (Create an Event)

Add an After Update Event 
You can also use the Property Sheet to add an 
After Update Event to automatically Refresh the 
records in the Subform when a User selects a 
Genre from the Combo Box.

The Rating Combo has an Embedded Macro as 
an After Update Event. The Genre Combo will 
have an Event Procedure in Visual Basic.

This example will be a simple introduction to the 
programming behind Microsoft Access. We will 
explore Microsoft Visual Basic for Applications 
(VBA) more in the next lesson. 

4. Try it: Add an After Update Event
Select the Genre Combo Box Control.
Go to Property Sheet->Event.
Click on After Update.
Select: Event Procedure.

Click on the 3-Dot Builder.

Keep going, please...

Form Design Tools->Design->Tools->Property Sheet
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form: Modify Existing Forms (Create an Event)

Hello, Microsoft Visual Basic! 
Clicking on the 3-Dot Builder should open a new 
program: Microsoft Visual Basic for Applications. VBA is 
a programming language.

5. Try it: Review the Code
The Visual Basic editor lists the objects on the left side 
and the code on the right in the big pane. 

Form_MovieSearch is selected. 
There is an AfterUpdate Event for the GenreCombo.

The code begins with: Private Sub,
where Sub means Subroutine.

The code ends with: End Sub. 

Keep going...

Visual Basic for Applications
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form: Modify Existing Forms (Create an Event)

Edit the Code 
The command to Refresh the Records is the 
same in Visual Basic as it is in the Macro that 
we added to the Rating Combo.

6. Try it: Edit the Code
Type: Refresh

Do This, Now: Save the Programming
Go to File->Save.

That's it. Now you are a *real* programmer. 

Close the VBA Window. You should return to 
your Mighty Access database. 

Keep going...

Visual Basic for Applications
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Test the Form 
Well, does it work? The only way you will know 
is to enter data into the Form as any User 
would: in Form View.

Before You Begin: Change the View
Go to Form Design Tools->Views.
Select a View: Form View.

7. Try it: Test the Form
Select a Rating: PG13
Select a Genre: Comedy.

What Do You See? The two Combo Boxes 
filter the movie list. 

What Else Do You See? The movies in the 
Subform automatically update whenever a 
Rating or Genre is selected. 

Well done!

Form Design Tools->Views->View->Form View
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Cool Combo Boxes 
This lesson created a Genre Combo 
Box that looks up the Rating on the 
MovieSearch Form. The two Combo 
Boxes are synchronized because the 
first one sets the criteria for the 
second. We also added a little bit of 
code to Refresh the movies in the 
Subform automatically after the Rating 
or Genre change. 

Well, I'd say you done good. For this 
one, you can get the whole row of 
cookies if you wish.
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Lesson 5: Form and Subform Design, part 3
Try This: Do the following steps
1. Open the Brown Bag Lunch database you have been working on. 
Or, you may download BBL Int ver5.accdb. 
2. Create a new Table. Add the following fields and data types:
SpecialtyID, AutoNumber
Specialty, Text
Make SpecialtyID the Primary Key.
3. Save the Table as tblSpecialty.
4. Go to Datasheet View and add the following to the Specialty column:
Gluten Free, Vegetarian, Low-Fat.
Save and close tblSpecialty.
5. Using the Query Design command, create a new Query.
Using the Show Table dialogue box, add the following Tables: tblProducts, 
tblType, and tblSpecialty. Close the Show Table dialogue box.
6. Join the Tables. Select field Type from tblProducts and drag it to the 
matching field, Type, in tblType. Then, select the Specialty Field in 
tblProducts and drag it to the Specialty field in tblSpecialty.
7. In the QBE grid, add the following fields to the Query:
from tblSpecialty: Specialty
from tblType: Type
from tblProduct: Item
8. Sort the Specialty Field in Ascending order
9. Save the Query as TypeSearchSQ. Run the Query to test it.

10. Return to Design View. Delete the Field: Item
11. Use the Show/Hide Totals command. Keep the setting “Group By”
12. Add the Criteria “Is Not Null” for the Specialty Field. 
13. In the Criteria for the Type Field, right click and select Build. Select the 
current Database, the Form: Product Search, and the Control: Type Combo. 
Double Click the TypeCombo to add it to the Expression. 
Save and close the Query. 
14. Open the Product Search Form in Design View. Add a new Combo Box 
in the Detail section of the Form.
15. In the Combo Box Wizard, choose to get the values from TypeSearchSQ. 
Add the available Field: Specialty. Sort by Specialty in Ascending order.
16. Store the value in the Specialty Field.
17. Add the Label Specialty and Finish the Wizard. 
16. Review the Property Sheet and rename the Combo Box as 
SpecialtyCombo. Save the Form. 
17. Select the Subform. In the Property Sheet, edit the option for Link Master 
Field. Add a second field: Specialty to link.
18. Select the Specialty Combo Box. Add an event: After Update. Select an 
Event Procedure, then use the 3-Dot Builder to edit the Event.
19. Using the Visual Basic editor, add the code Refresh. Save and close the 
Macro.
20. Return to Form View and test the form. Change the Type to Snacks. 
Select an option in the Specialty box. Change the Type to Sandwich and 
select Gluten Free. What do you see? 
21. Save the database. 

Practice Activities
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1. You can have a Table and a Form both 
open in Design View at the same time.
A. True
B. False 
Tip: Intermediate Access, page 125

2. A Query can use more than one Table 
for Data.
A. True
B. False
Tip: Intermediate Access, page 127

3. Which of the following is true? 
(Give all correct answers.)
A. Joining Tables creates a relationship 
between them
B. Joining Tables is done by matching 
fields on different Tables that have the 
same data type
Tip: Intermediate Access, page 128

4. Which of the following are columns in 
the Expression Builder? 
(Give all correct answers.)
A. Expression Elements
B. Expression Categories
C. Expression Values
Tip: Intermediate Access, page 134

5. A Form and Subform can be linked by 
two Fields.
A. True
B. False
Tip: Intermediate Access, page 145

Test Yourself
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© 2014 Comma Productions, LLC

Access 2013: Designing for Users

Intermediate Access Objectives
In this lesson, you will learn how to: 
1. Create a Blank Form and edit it in Design View to 
include a Logo, Background Image and Text Box.
2. Use the Command Button Wizard to create a 
Embedded Macro that opens another Form.
3. Edit the Embedded Macro and test the code.
4. Apply Quick Styles to the Controls in a Form
5. Convert the Macros to Visual Basic.

Meet the Stars
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1. Readings
Read Lesson 6 in the Beginning Access 
guide, page 153-186.

Project
Create a switchboard: an Unbound Form 
with Command Buttons that open Forms.

Downloads
FrontRowVideo Int6.accdb
popcorn1.gif, popcorn2.gif, 
popcorn3.gif, 
popcorn4.gif, movies1.gif.

BBL Int ver6.accdb
BB Customers Logo.jpg
Brown Bag Logo.jpg
Lunch1.gif, Lunch2.gif, Lunch3.gif, 
Lunch4.gif

2. Practice
Do the Practice Activity on page 187.

3. Assessment
Review the Test questions on page 188.

Menu Maps
From the Form Design Tools->Design Ribbon
1. Form Design Tools ->Design->Controls->Textbox, page 159
2. Form Design Tools ->Design->Header Footer->Logo, page 160
3. Form Design Tools ->Design->Controls->Button, page 163
4. Form Design Tools ->Design->Tools->Property Sheet, page 169
5. Form Design Tools ->Design->Tools->Convert Form's Macros to Visual Basic, page 181

From the Form Design Tools->Format Ribbon
1. Form Design Tools ->Format ->Font, page 161
2. Form Design Tools ->Format ->Background Image, page 162
3. Form Design Tools ->Format->Control Formatting->Quick Styles, page 170

Form Design Tools->Design Ribbon

Form Design Tools->Design Ribbon

Lesson 6 : Meet the Stars
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Example of a Switchboard Form in Microsoft Access 2013

"Pay No Attention to the Man Behind the Curtain!"
A commercial database never reveals the Form, Table, and Query designs. That would be like putting on a 
play and letting the audience see the backstage scaffolding, ropes and ladders. It simply isn't done. Allowing 
Users to edit the data directly in a Table is also a security risk. 

Good databases open with an option menu, or switchboard. Some menus are simple: a list of tasks. Others 
use the option menu to help the users navigate. In this lesson, we will create a switchboard and learn some 
simple programming. In the next lesson, we will hide the database window and program what the User sees 
when the database opens.

Comma Training Page 155

Microsoft Access 2013 Inermediate   Page 155 of 281



What Are the Objectives? 
A Switchboard is a Form with Command 
Buttons. This Form does not need a Table or a 
Record Source because it is not editing any data. 
So, it is considered Unbound. The Switchboard is 
simply a menu or map of what is in the database.

A Command Button is a Shape that responds to 
an Event. One example is the On Click Event. 
When a User clicks a button a Form or Report will 
open.

Create an Unbound Form
Add Labels and Logos

Add Command Buttons
To open two Forms: Movies, Customers.
To open one Report: Movies by Year

Add Buttons to Return to the Switchboard
From the Movies and Customers Form.

That's the scope of this lesson.

Example of a Switchboard Form in Microsoft Access 2013
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: View All Access Objects

Before You Begin 
Before You Begin: Open the Sample Database
Go to Start -> Microsoft Access 2013.

Access will prompt you to open a database. 
This lesson uses the database that was programmed in 
the previous lesson. You can continue with the same 
database if you wish. 

The FrontRowVideo Int6.accdb database has:
Five Tables: tblCustomers, tblGenre, tblMovies, 
tblMovieSearch and tblRating.

Six Queries: CustomerHomePhoneSQ, 
CustomerNameSQ, MoviesByYearSQ, MovieSQ,, 
MovieSearchSQ and RatingSearchSQ.

Four Forms: Customers, Movies, MovieSearch and 
MovieSearchSubform.

Two Reports: Movies by Year, Customer Name.

Keep going...

Memo to Self: Click Enable Content if you see the 
Security Warning. 

Start ->Microsoft Access 2013

Comma Training Page 157

Microsoft Access 2013 Inermediate   Page 157 of 281



Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.1 Create a Form: Create New Forms

Create a New, Blank Form 
The Switchboard Form does not save any 
data, so it does not have a Table or Query 
for the Record Source. 

1. Try This: Create a New, Blank Form
Go to Create->Forms->Blank Form

What Do You See? A new, blank Form should 
open in Form View.

Try This, Too: Change the View
Go to Home->Views.
Select a View: Design View.

Keep going...

Create->Forms->Blank Form

Comma Training Page 158

Microsoft Access 2013 Inermediate   Page 158 of 281



Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Add Form Controls (Calculated Control Source)

Switchboard: Add a Textbox 
2. Try it: Add a Textbox
Go to Form Design Tools ->Design->Controls.
Select a Control: Textbox.
Click on the Form Detail.

What Do You See? There should be a new, unbound 
Textbox on the Form. 

Try This, Too: Edit the Textbox Properties
Select the Textbox.
Go to Form Design Tools ->Design.
Go to Tools->Property Sheet.

Edit the Textbox Properties:
Name: Today
Control Source: =Now()
Format: Long Date
Width: 3"

Edit the Label Properties:
Select the Label.
Edit the Caption: Today is

Keep going...

Form Design Tools ->Design->Controls->Textbox
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form: Insert Headers and Footers (Add Logo)

Switchboard: Add a Logo
3. Try it: Add a Logo
Go to Form Design Tools ->Design.
Go to Header Footer->Logo.

You will be prompted to Browse for an image. 
Go to the Documents folder.
Select an image: movies1.gif

What Do You See? There should be a new logo 
image in the Form Header.

Try This, Too: Edit the Textbox Properties
Select the movie image.

Edit the Image Properties:
Name: FrontRowLogo
Size Mode: Zoom
Picture Alignment: Center
Width: 1.5"
Height: 1"
Top: 0.0208"
Left: 0.0208"

Keep going...

Form Design Tools ->Design->Header Footer->Logo
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Manage Labels

Switchboard: Add a Label 
4. Try it: Add a Label
Go to Form Design Tools ->Design->Controls.
Select a Control: Label.
Click on the Form Header.
Type: Front Row Video

What Do You See? There should be a new Label on 
the Form Header. 

Try This, Too: Edit the Label Properties
The Label is still selected.
Go to Form Design Tools ->Design->Tools.
Click on Property Sheet and edit the following:
Name: Banner
Caption: Front Row Video
Width: 3.5"
Height: 0.65"
Top: 0.125"
Left: 1.5"
Font Size: 36

What Else Do You See? You can format the Label 
Font color, size and alignment with the Format Ribbon 
or the Property Sheet if you wish. 

Keep going...

Form Design Tools ->Design->Tools->Property Sheet

Comma Training Page 161

Microsoft Access 2013 Inermediate   Page 161 of 281



Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Insert Backgrounds

Apply Background Image
5. Try it: Apply Background Image
Go to Form Design Tools ->Format.
Click on Background Image.

You will be prompted to Browse for an image. 
Go to the Documents folder.
Select an image: movies1.gif
Click OK.

What Do You See? There should be a picture of 
movies in the background of the Form Detail.

Do This, Now: Save the Form
Go to File->Save.
Enter the name: Switchboard.

So far, so good. 

Form Design Tools ->Format ->Background Image
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Create Navigation Forms (Switchboard)

Add a Command Button  
A Command Button does an action: something 
opens, calculates or prints when you click the button. 
Our first button will open the Movies Form. 

1. Try it: Add a Command Button
Go to Form Design Tools ->Design->Controls.
Select a Control: Button.
Click on the Form Detail.

What Do You See? The Command Button Wizard
should begin.  

Keep going..., the show's just gettin' good.

Form Design Tools ->Design->Controls->Button
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Create Navigation Forms (Switchboard)

Command Button: Action 
A Command Button can do many Actions. The 
Categories include:
Record Navigation
Record Operations
Form Operations
Report Operations
Application
Miscellaneous

Each Category has several Actions. 

2. Try it: Program the Action
Select a Category: Form Operations
Select an Action: Open Form

Click Next. 

Keep going...

Form Design Tools ->Design->Controls->Button
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Create Navigation Forms (Switchboard)

Command Button: Form 
3. Try it: Select Which Form Should Open
Select a Form: Movies
Click Next. 

Keep going...

Form Design Tools ->Design->Controls->Button
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database 1.3.1 Navigate to Specific Records

Command Button: Record 
When you open a Form, you can show all of the 
Records, or only the one(s) that match your 
criteria. This Button will open the Movies Form and 
show all of the records in tblMovies. 

4. Try it: Select the Records
Click: Open the form and show all the records.

Click Next. 

Keep going...

Form Design Tools ->Design->Controls->Button
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Create Navigation Forms (Switchboard)

Command Button: Text 
The Command Button Wizard gives you the 
option to use Text or Pictures for the 
Command Button. It is an interesting question. 
Many Users navigate by images.

For example, directions may be given in 
landmarks. "Turn at the McDonalds." Many 
other Users also navigate by names: Go to 
Main Street." 

5. Try it: Select Text or Picture
Enter the Text: Movies

Click Next

Form Design Tools ->Design->Controls->Button
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Create Navigation Forms (Switchboard)

Command Button: Name  
6. Try it: Name the Button
Enter the name: OpenMoviesFrm
Click Finish.

What Do You See? There should be a little 
Command Button in the Detail Section of the 
Switchboard Form. 

Keep going... There are a few more steps. 

Form Design Tools ->Design->Controls->Button
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Create Navigation Forms (Switchboard)

Edit the Button Properties 
7. Try it: Edit the Button Properties
Select the OpenMoviesFrm Button.

Edit the Command Button Properties:
Caption: Movies
Width: 2"
Height: 0.4"
Top: 0.5"
Left: 0.5"
Use Theme: Yes

Keep going, you want to see this.

Form Design Tools ->Design->Tools->Property Sheet

Comma Training Page 169

Microsoft Access 2013 Inermediate   Page 169 of 281



Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form: Apply Themes (Quick Styles)

Apply a Quick Style
8. Try it: Apply a Quick Style
The Command Button is selected.
Go to Form Design Tools ->Format.
Go to Control Formatting->Quick Styles.
Select a Style: Intense Effect- Red, Accent 2

Keep going...

The Computer Mama Sez: This formatting was 
new to Microsoft Access 2010. 
It's a lot of fun!

Form Design Tools ->Format->Control Formatting->Quick Styles
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Create Navigation Forms (Switchboard)

Add More Stars
9. Try it: Add A Button for the Customers
Go to Form Design Tools ->Design->Controls.
Select a Control: Button.
Click on the Form Detail.

Select a Category: Form Operation
Select an Action: Open Form
Select the Form: Customers
Choose the Records: All Records
Enter the Text: Customers
Name the Button: OpenCustomersFrm

Try This, Too: Add A Button for a Report
Select a Category: Report Operation
Select an Action: Preview Report
Select the Report: Movies by Year
Enter the Text: Movies by Year
Name the Button: OpenReportMoviesByYear

Edit the following Properties for each button:
Width: 2"
Height: 0.4
Apply a Quick Style.
You can place the buttons similar to layout in the 
screenshot on this page if you wish.

Form Design Tools ->Format->Control Formatting->Quick Styles
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Test the Switchboard Form
There is only one way to see if the buttons work: 
open the Switchboard Form in Form View and try 
it like a User.

Do This, First: Save the Form Design
Go to File->Save.

1. Try This: Change the View
Go to Form Design Tools ->Design->Views.
Choose a View: Form View.

What Do You See? The Switchboard has the 
current date in a Text Box. There are two Buttons 
to open the Forms. There is a third Button that 
opens a Report in Print Preview.

Form Design Tools ->Design->Views->View
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Use Navigation Forms

Test the Command Buttons 
2. Try it: Test the Command Buttons
Click on: Customers.

What Do You See? The Customers Form 
should open in a new Window, to the right of 
the Switchboard Form.

What Do You Think? There should be a way 
to Close the Customers Form and Return to 
the Switchboard when you are done editing 
the Customers' Records. 

There are two parts to this programming:
Open the Switchboard Form.
Close the Customers Form. 

Let's begin by adding a Home Button to open 
the Switchboard Form. 

"We are not responsible 
for the weather"  
-Katherine Hepburn as 
Rose Sawyer 

Home
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Create Navigation Forms (Switchboard)

There And Back Again 
Before You Begin: Change the View
The Customers Form is open.
Go to Home->Views->View.
Choose a View: Design View.

3. Try it: Create a Home Button
Go to Form Design Tools ->Design->Controls.
Select a Control: Button.
Click on the Form Header.

Select a Category: Form Operation
Select an Action: Open Form
Select the Form: Switchboard
Enter the Text: Home
Name the Button: GoHome
Click Finish to close the Wizard. 

Try This, Too: Edit the Button Properties
Width: 2"
Height: 0.4
Top: 0.125"
Left: 5" 

Save your changes. 

Keep going...

Form Design Tools ->Design->Controls
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Create Navigation Forms (Switchboard)

Test the Home Button 
Before You Begin: Change the View
The Customers Form is open in Design View.
Go to Form Design Tools ->Design->Views.
Choose a View: Form View.

4. Try it: Test the Home Button
Click on the Home button on the Customers Form.

What Do You See? The Switchboard will open.

What Else Do You See? There are two Forms open. 
Now, we need to add the code that closes a Form 
when you are done with it.

Keep going...

Rick: "Who are you really? 
And what were you 
before? What did you do 
and what did you think? 
Huh?"

Form Design Tools ->Design->Views->View
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form: Modify Existing Forms (Create an Event)

Behind the Scenes 
When you used the Command Button Wizard you 
created an Embedded Macro. This is a new 
format for Microsoft Access 2007 and 2010. It 
cannot be edited by any previous version of 
Access. This demonstration will show you how to 
review and edit the Macro. 

5. Try This: Review the Embedded Macro
Open the Customers Form in Design View. 
Select the Home Button.

Go to Property Sheet->Event.
Go to the On Click Event.
Click Embedded Macro. 

Do you see the three-dot builder? 
Click the builder. 

Keep going...

Memo to Self: Why call the Switchboard Button, 
"Home?" On the Internet, Home means the first 
page in a website. The concept works here in a 
database, too. It is a term people use to navigate. 

Form Design Tools ->Design->Views->View
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form: Modify Existing Forms (Create an Event)

Review the Macro 
When you invoke the 3-dot Builder, a new 
Window should open. The Macro Tools should 
be available as well. 

6. Try it: Review the Macro
The Code for the GoHome Macro is open.
The Macro Tools are available.

The Macro begins with: OpenForm
Form Name: Switchboard
View: Form

Keep going...

Form Design Tools ->Design->Tools->Property Sheet->Event
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form: Modify Existing Forms (Create an Event)

Add to the Macro
Our goal is to close the Customers Form when 
we click to return Home, to the Switchboard. 
Here are the steps.

7. Try it: Add to the Macro
Click green plus sign to add a new Action.
Select an Action: CloseWindow

Keep going...

Form Design Tools ->Design->Tools->Property Sheet->Event
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form: Modify Existing Forms (Create an Event)

Edit the Code Arguments 
What Do You See? A editor will open. Each 
variable in the code has a place.

8. Try it: Edit the Arguments
Please select the following:
Object Type: Form
Object Name: Customers
Save: Yes

Try This, Now: Save the Macro
Go to Macro Tools->Design->Save.
Click Close. 

Keep going...

Memo to Self: You want to open the new 
Form before you close the old one!

Macro Tools->Design->Save
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form: Modify Existing Forms (Create an Event)

Test the Command Button 
Before You Begin: Change the View
The Customers Form is still open in Design View.
Go to Form Design Tools ->Design->Views.
Choose a View: Form View.

9. Try it: Test the Updated Command Button
Click the Home Button on the Customers Form. The 
Customers Form should close. 
The Switchboard Form (Home) should be open. 

What do you think, now?

Impressive.

Form Design Tools ->Design->Views->Form View
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form: Modify Existing Forms (Convert Macros to VBA)

Convert the Form Macros to VBA
Macros are one method of programming actions in 
your Mighty Access database. As we saw in the 
previous lesson, Visual Basic for Applications (VBA) is 
another.

Before You Begin: Change the View
The Customers Form is open in Form View.
Go to Form Design Tools ->Design->Views.
Choose a View: Design View.

1. Try it: Convert the Form's Macros to VBA
Go to Form Design Tools ->Design->Tools.
Click: Convert Form's Macros to Visual Basic.

You will be prompted to select the following:
Add error handling to generated functions.
Include macro comments.

Click Convert. 

Now, What Do You See? In a few seconds, a pop up 
will say: Conversion Finished!

Click OK. Keep going...

Form Design Tools ->Design->Tools->Convert Form's Macros to Visual Basic
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form: Modify Existing Forms (Convert Macros to VBA)

Review the Event Procedure 
When the process is done, the Embedded 
Macros on this Form will be converted to Event 
Procedures.

2. Try it: Find the Event Procedure
The Customer Form is open in Design View.
The "GoHome" Button is selected.

Go to Property Sheet->Event->On Click.

What Do You See? There is an Event 
Procedure that will run whenever a User clicks 
on this Button.

Try This, Too: Review the Event Procedure
Click on Event Procedure.
Click on the 3-dot Builder.

The Visual Basic for Applications Windows 
should open. Curious? 

Keep going...

Memo to Self: The Conversion from Macro to 
VBA is for this Form, only. 

Form Design Tools ->Design->Tools->Convert Form's Macros to Visual Basic
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.3 Format a Form: Modify Existing Forms (Convert Macros to VBA)

Review the VBA Code
3. Try it: Review the Code
The Code begins with: Private Sub
It must finish with: End Sub
"Sub" means subroutine.

The first Action is: DoCmd.Open Form
Where "Switchboard" is the Form name.

The second Action is: DoCmd.Close
Where "Customers" is the Form name.

Error Trapping
The rest of the code looks for errors. If you 
spell the name of the form wrong, the 
subroutine should catch that mistake and bring 
up a message box (MsgBox).

Error trapping is a good thing. It keeps the 
computer from running around in circles if it 
can't figure something out.

Please Save and Close the VBA editor.

When you return to your Access database, 
Save and Close the Customer Form.

Microsoft Visual Basic for Applications
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Create Navigation Forms (Switchboard)

Add a Button to Each Form 
4. Try This: Finish the Switchboard Form
For each Button on the Switchboard Form, edit the 
Event and add the code that will close the 
Switchboard Form when you open another Form.

Try This, Too: Add a Button to Each Form
Please include the "GoHome" code to open the 
Switchboard Form as well as the code to close the 
Form that you are currently on.

It seems like a silly exercise, but it is one your Users 
will appreciate. 

Form Design Tools ->Design->Controls
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Create Navigation Forms (Switchboard)

A Hard Day's Night 
It's Quitting Time! Let's give the Users a way to quit. 
Here is a simple Button that will close your Microsoft 
Access Database.

5. Try it: Add an Application Button
Open the Switchboard Form in Design View. 
Go to Form Design Tools ->Design->Controls.
Choose a Control: Button.
Click on the Form Detail.

The Command Button Wizard will ask you to:
Select a Category: Application
Select an Action: Quit Application
Enter the Text: Quit App
Name the Button: QuitApp
Click Finish. 

What Do You See? There should be another Button 
on the Switchboard Form. You can format the Control 
to match the others if you wish. 

Save your programming. Change the View back to 
Form View. Go ahead, try the Buttons. 

Form Design Tools ->Design->Controls
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Summary 
This lesson created a Switchboard with 
Command Buttons. A Command Button is a 
Shape that responds to an Event. 

We used the Command Button Wizard to add 
Buttons to open:
Two Forms: Movies, Customers.
One Report: Movies by Year

We also added a "GoHome" Button to the 
Movies and Customers Forms that Users can 
click to return to the Switchboard.

The next lesson continues with the "Opening 
Scene." What do the Users see when they 
start up your Access Database?

You done good. Go get a cookie and come 
back when you are ready.
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10. Add a Command Button that opens the Products Form.
Choose to show all Records.
11. Use the text Products on the Button. Name the button OpenProductsForm.
12. Edit the command button properties: Width 2” and Height 0.4”
13. Create a Command Button that opens the Customers Form.
14. Use the text Customers on the Button. Name the button OpenCustomersForm.
15. Edit the command button properties: Width 2” and Height 0.4”
16. For both the Products and Customers buttons, click on the On Click Event and 
edit the Embedded Macro with the 3-dot builder.  For OpenProductsForm and 
OpenCustomersForm close the Switchboard after the Form is opened. Don't Save.
17. Return to Form View and test each command button. Does the right Form open? 
Does the Switchboard close when the other Form opens?
18. On both the Products and Customer Forms, add a Home button that opens the 
Switchboard Form. Use the text Home on the Button and the name GoHome. For 
both the Products and Customers buttons, click on the On Click Event and edit the 
Embedded Macro with the 3-dot builder to close the Switchboard after the Form is 
opened. YES, Save the Form data.
19. Return to the Switchboard. Add a new Command Button that opens the Report 
Products by Type. 
20. Use the text Products by Type on the Button. Name the button 
OpenProdbyTypeReport
21. Edit the command button properties: Width 2” and Height 0.4”
22. Add a new Command Button that uses the Quit App command. 
23. Use the text Quit on the Button. Name the button QuitApp
24. Edit the command button properties: Width 2” and Height 0.4”

Lesson 6: Meet the Stars!
Try This: Do the following steps
1. Open the Brown Bag Lunch database you have been working 
on. Or, you may download BBL Int ver6.accdb. 
2. Create a new Blank Form and go to Design View.
3. Add an Unbound Text Box. Use the Property Sheet to add the 
Control Source: =Now()
4. Apply Medium Date and set the width to 2”
5. Edit the Text Box label to say: Today’s Date.
6. Add a Logo in the Form Header. 
Use the image: Brown Bag Logo.jpg. Edit the image properties:
Name: BBLunchLogo
Width: 1”
Height: 1”
Top: 0.25”
Left: 0.25”
7. Add a Label to the Form Header. Edit the following properties:
Name: Banner
Caption: Brown Bag Lunch Co.
Width: 4”
Height: .75”
Font Size: 24
8. Add a background image: Lunch1.gif
9. Save the Form as Switchboard.

Practice Activities
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1. Which is true about a Switchboard? 
(Give all correct answers.)
A. A menu of options
B. A Form made up of Command buttons
C. An Unbound Form
Tip: Intermediate Access, page 156

2. Which is true about a Switchboard? 
(Give all correct answers.)
A. A Switchboard saves data
B. A Switchboard does not save data
C. A Switchboard does not have a Table or 
Query as a Record source
D. A Switchboard uses a Query only as its 
Record source
Tip: Intermediate Access, page 158

3. Which are Command button Categories?
(Give all correct answers.)
A. Record Navigation
B. Form Operations
C. Report Operations
D. Miscellaneous
Tip: Intermediate Access, page 164

4. Which is an option for opening a Form with a 
Command button? 
(Give all correct answers.)
A. Open the form and find specific data to display
B. Open the form and show all records
Tip: Intermediate Access, page 166

5. The Quit Application command closes just the 
open database and leaves the program Access 
open.
A. True
B. False
Tip: Intermediate Access, page 185

Test Yourself

"It's not confidence, ma'am; 
it's honesty"
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© 2014 Comma Productions, LLC

Access 2013: Designing for Users

Intermediate Access Objectives
In this lesson, you will learn how to: 
1. Set the Microsoft Access Application 
options for the Current Database.
2. Display a Form when the database opens.
3. Do not display the Navigation Pane when 
the database opens.
4. Use the Form Properties to remove the 
Record Selectors, Navigation Buttons, Scroll 
bars, Control Box, Close Button, and the Min 
Max Buttons. 

The Opening Scene
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1. Readings
Read Lesson 7 in the Intermediate Access 
guide, page 189-203.

Project
Change the Start Up Options to display a 
Form when the database opens. Edit the 
Properties on the Switchboard Form. 

Downloads
FrontRowVideo Int7.accdb
BBL Int ver7.accdb

2. Practice
Do the Practice Activity on page 204.
3. Assessment
Review the Test questions on page 204.

Menu Maps 
From the Backstage
File->Options, page 194
File->Options->Current Database, page 195

From the Form Design Tools->Design Ribbon
1. Form Design Tools->Design->Tools->Property Sheet, page 200

Form Design Tools->Design Ribbon

Lesson 7 : The Opening Scene
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Setting the Stage
Some people are afraid of databases. They don’t want to 
see the database properties. They are allergic to Queries 
and Tables. Just give them a button to push and a Form 
to fill out so they can get their work done. 

Other people are curious. They like to take things apart: 
with or without learning how it all works. 

You are the director: You decide what should be seen 
and when it shouldn’t. You can also set the stage and 
control the action. A good director leads the audience 
where they are supposed to go. In this lesson, we will 
look at how the database opens. 

The Opening Scene

"Something Wicked This Way Comes!" 
Macbeth, by Shakespeare
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What Are the Objectives?
The database can display a Switchboard Form when 
the program opens. The Switchboard gives Users 
someplace to start. In this lesson we will:

Edit the Application Options:
Display a startup Form, the Switchboard

Edit the Navigation Options:
Show or hide the Navigation Pane

Edit the Switchboard Form Properties
Remove the Windows Controls in Design View
Minimize the Ribbons in Form View

That's the plan. 

Microsoft Access: Example of a Switchboard Form
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: View All Access Objects

Before You Begin 
Before You Begin:Open the Sample Database
Go to Start ->Microsoft Access 2013.

Access will prompt you to open a database. 
This lesson uses the database that was programmed in 
the previous lesson. You can continue with the same 
database if you wish. 

The FrontRowVideo Int7.accdb database has:
Five Tables: tblCustomers, tblGenre, tblMovies, 
tblMovieSearch and tblRating.

Six Queries: CustomerHomePhoneSQ, 
CustomerNameSQ, MoviesByYearSQ, MovieSQ, 
MovieSearchSQ and RatingSearchSQ.

Four Forms: Customers, Movies, MovieSearch and 
MovieSearchSubform.

Two Reports: Movies by Year, Customer Name.
Keep going...

Memo to Self: Click Enable Content if you see the 
Security Warning. 

Start -> Microsoft Access 2013
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: View All Access Objects

Backstage Pass
In this Mighty Access Database, the Front Row Video 
Switchboard Form will take center stage. When the 
database opens, the User will see a Home menu with 
simple choices. Everything else—including the database 
objects in the Navigation Pane—should be invisible to 
the user.   

1. Try it: Find the Options
Click on File. 

The Backstage has the following:
Info
New
Open 
Save
Save As 
Print
Close
Account 
Options

2. Try it: Change the Options
Go to File->Options. 

Keep going...

File->Options
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Access Options (Current Database)

Current Database Options 
The Access Options include many places where 
you can customize the database. 

The categories include the following:
General
Current Database
Datasheet
Object Designers
Proofing
Language
Client Settings
Customize Ribbon
Quick Access Toolbar
Add-ons
Trust Center

2. Try This: Review the Current Database
Go to Current Database. 

What Do You See? By default, the Application 
Options are blank. 

Keep going...

File->Options->Current Database
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Set a Form as the Startup Option

Edit the Current Database 
3. Try This: Edit the Application Options
Application Title: Front Row Video
Display Form: Switchboard
Display Status Bar: Yes
Document Window Options
Tabbed Documents: Yes
Display Document Tabs: Yes

Try This, Too: Edit the Navigation Options
Display Navigation Pane: No

Click OK. 

Keep going...

File->Options->Current Database
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Set a Form as the Startup Option

Reopen the Current Database 
The changes we just made will show up when you 
reopen the database.

4. Try it: Confirm and Reopen the Database
You will be prompted to close and reopen the current 
database for the options to take effect.

Click OK. 
Close the database and Open it again. 
Keep going...

File->Options->Current Database
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Set a Form as the Startup Option

The Opening Scene 
5. What Do You See? The database opened and 
displayed the Switchboard Form. The Title at the 
top of the database says Front Row Video, not 
Microsoft Access. 

What Don't You See? There is a Record Selector 
on the right side of the Switchboard Form. The 
Navigation Pane is hidden.

Try This, Too: Show the Navigation Pane
The Navigation Pane lists all of your Microsoft 
Objects: Tables, Forms, Queries and Reports. We 
still have a lot of programming to go through. 
Please change the options for the Current 
Database.

Go to File->Options->Current Database.
Edit the Navigation options:
Display Navigation Pane: Yes
(We are turning the Pane back on, again.)
Click OK to close the Options.
Click OK when you are prompted to reopen.

Close the database and Open it again.

Keep going...

File->Options->Current Database
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Edit Form Control Properties

Designing for Users 
In an earlier lesson, we used the Property Sheet to 
edit a couple of Form Properties: Tab Order and 
Cycle. The Property Sheet can also control what a 
User can see or edit. In an earlier lesson, we also 
mentioned that Real Users get Real Mad when a 
Form does not act as expected.

Let's review the options and look for ways to make 
our Form more effective.

1. Try it: Review the Form
Go to All Access Objects->Forms.
If needed, open a Form: Switchboard.

What Do You See? The Switchboard Form has 
Record Selectors and Navigation Buttons. Since the 
Switchboard Form does not save any data, there is 
no need to use the Record Selectors or find a 
different Record. We can turn those features off in 
the Property Sheet. 

Home->Views->View->Form View
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Edit Form Control Properties

Controlling Form Properties 
What happens when a User closes the 
Switchboard in this Mighty Access Database? 
How will she get back to work if the Navigation 
Panel is hidden? As a database designer, you can 
be proactive and remove the Close Button.

Before You Begin: Change the View
The Switchboard Form is open in Form View.
Go to Home->Views->View->Design View.

2. Try it: Edit the Form Properties
Click on the Form Selector.
Go to the Property Sheet->All.

Edit the following Properties:
Auto Resize: Yes
Fit to Screen: Yes
Record Selectors: No
Navigation Buttons: No
Scroll Bar: Neither
Control Box: No
Close Button: No
Min Max Buttons: None
Moveable: No
Save your changes. 

Keep going...

Form Design Tools->Design->Tools->Property Sheet
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Access Options (Quick Access Toolbar)

Collapse the Ribbons
The Ribbons allow Users full control of your 
Access Database. The Ribbons--Home, Create, 
External Data and Database Tools--have many 
functions that could damage the data if someone 
doesn't know how to use them correctly. Some 
actions have no "Undo."

3. Try This: Collapse the Ribbon
Right-click the Home Ribbon. 
Select an Option: Collapse the Ribbon.

Keep going...

Home->View->Views->Form View
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Access Options (Quick Access Toolbar)

A Simplified Form 
4. What Do You See? This Form has 
been stripped of several Controls 
including the Records Selector, 
Navigation Buttons and Scroll Bars. 

The Windows Controls are also hidden: 
Min, Max and Close. 

The Ribbons are hidden, but this is not 
real security. Users can still see the 
Menus. 

That's good enough for now.

Home->View->Views->Form View

Comma Training Page 202

Microsoft Access 2013 Inermediate   Page 202 of 281



Summary
There are lots of ways that a 
User can be confused by a Form. 
We just used a half-dozen 
Properties to simplify the 
Switchboard Form. 

You done good.
You get the cookie.
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1. Which of the following is listed in the 
Access Navigation Pane? 
(Give all correct answers.)
A. Tables
B. Forms
C. Queries
D. Reports
Tip: Intermediate Access, page 198

2. The Property Sheet allows access to 
remove which commands from Access?
(Give all correct answers.)
A. Record Selectors
B. Navigation buttons
C. Scroll Bar
D. Close button
E. Mix and Max buttons
Tip: Intermediate Access, page 200

3. Which is the command for Minimizing 
the Ribbon?
A. Right click the Ribbon and select Hide
B. Right click the Ribbon and select 
Collapse
C. Go to File-> Options-> Ribbons
Tip: Intermediate Access, page 201

Lesson 7: The Opening Scene
Try This: Do the following steps
1. Download the database BBL Int ver7.accdb. 
It is not recommended that you use the database you 
have been programming because this activity 
removes controls from view.
2. Open the Switchboard Form in Design View.
3. Using the Property Sheet, edit the following:
Record Selectors: No
Navigation Buttons: No
Scroll Bar: Neither
Control Box: No
Min Max Buttons: No
Movable: No
4. Go to File->Options. Go to Current Database. Edit 
the Application Options as follows:
Application Title: Brown Bag Lunch
Display Form: Switchboard
Display Status Bar: Yes
Document Window Options: Tabbed documents; 
Display Document Tabs=yes
Display Navigation Pane: No
5. Close and Reopen the database when prompted.
6. Minimize the Ribbons.
7. Review the database’s new look. 
8. You may close without saving. 

4. When the Ribbons are Minimized, the user 
cannot see or access them at all.
A. True
B. False
Tip: Intermediate Access, page 202

5. Which are reasons to remove controls in 
Access, such as the Navigation Pane and the 
Close button? (Give all correct answers.)
A. To keep the interface clean, simple and non-
threatening
B. To keep the database secure from damage 
by users
Tip: Intermediate Access, page 191

Practice Activity Test Yourself
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© 2014 Comma Productions, LLC

Intermediate Access Objectives
In this lesson, you will learn how to: 
1. Use the Property Sheet to troubleshoot 
Form errors.
2. Use the Query Tools to troubleshoot 
several common programming errors.

Access 2013: Designing for Users

Dress Rehearsal: Testing Software
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1. Readings
Read Lesson 8 in the Intermediate Access 
guide, page 205-219.

Project
A sample query to test errors.

Downloads
FrontRowVideo Int8.accdb

2. Practice
There is no Practice Activity for this lesson.

3. Assessment
Review the Test questions on page 220.

Menu Maps
From the Form Design Tools->Design Ribbon
1. Design->Tools->Property Sheet, page 209

Form Design Tools->Design Ribbon

Lesson 8 : Dress Rehearsal Software Testing

Comma Training Page 206

Microsoft Access 2013 Inermediate   Page 206 of 281



Microsoft Access 2013: Example of a Form with an error

Software should be tested in a lab—never live on the real company network. If your Mighty Access database 
doesn't work, at least it won’t keep the customers waiting. 

How should the testing be done? There are software products that can be programmed to run through a series of 
steps. These products are very accurate: the same test can be run many times. Even without sophisticated test 
software, you should thoroughly check your database. Each form needs to be inspected for function, tab order, 
even spelling. Does the database complete the task it was created to do?

Dress Rehearsal: Software Testing
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: View All Access Objects

Start -> Microsoft Access 2013

Before You Begin 
Before You Begin: Open the Sample Database
Go to Start -> Microsoft Access 2013.

Access will prompt you to open a database. 
This lesson uses the database that was programmed in 
the previous lesson. You can continue with the same 
database if you wish. 

The FrontRowVideo Int8.accdb database has:
Five Tables: tblCustomers, tblGenre, tblMovies, 
tblMovieSearch and tblRating.

Six Queries: CustomerHomePhoneSQ, 
CustomerNameSQ, MoviesByYearSQ, MovieSQ,, 
MovieSearchSQ and RatingSearchSQ.

Four Forms: Customers, Movies, MovieSearch and 
MovieSearchSubform.

Two Reports: Movies by Year, Customer Name.

Keep going...

Memo to Self: Click Enable Content if you see the 
Security Warning. 
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: View All Access Objects

Common Form Errors 
The following pages will set up several mistakes that are 
common in database programming: bad spelling and 
incomplete punctuation. After the error has been tested, 
we will undo the mistakes and confirm that the Form or 
Query works again.

1. Try This: Create a Typo
Go to All Access Objects->Forms.
Open a Form in Design View: Movies.
Select a Control: Movie.
Go to the Property Sheet->All.
Select the Control Source: Movie.

What Do You See? The Control Source drop down lists 
all of the Fields in the Record Source for this Form: 
tblMovies. 

Keep going...

Form Design Tools ->Design->Tools->Property Sheet
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Edit Form Control Properties

Misspell the Control Source  
2. Try it: Spell the Name Wrong
The Movie Control is still selected.
Go to the Property Sheet.
Rename the Control Source (type): Movies.
(It does not MATCH any Field in the Table.)

Keep going...

Form Design Tools ->Design->Views->View
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Exam 77-424: Microsoft Access 2013
4.0 Create Forms 
4.2 Set Form Controls: Edit Form Control Properties

The Screen Test 
3. Try This, Now: Change the View
Go to Form Design Tools ->Design->Views.
Select a View: Form View. 

What Do You See? There is an error on the Form: 
#Name? Microsoft Access cannot match the name 
of the Control Source in the Property Sheet with the 
Field in tblMovies. 

Do This, Now: Correct the Error
Go to Form Design Tools ->Design->Views.
Select a View: Form View.

Select the Movie Control.
Go to the Property Sheet.
Select the Control Source: Movie.

Save your changes. 
Test the Form in Form View, again.

Done and done. Close the Form.

Form Design Tools ->Design->Views->View
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.1 Create a Query : Edit Queries

Common Query Errors 
There are several common Query errors. Each 
mistake has it a different error message. The 
following pages will look at two Query mistakes: 
punctuation and spelling.

1. Try This: Create a Sample Query
Go to Create ->Queries-> Query Design.
Select a Table: tblCustomers
Click Add. Click Close

Try it: Add Fields to the Query
Go to tblCustomer.
Double click to select the following Fields:
CustomerID
FirstName
LastName

Try it: Concatenate Two Name Fields
Place your cursor in Column 4.
Type: FullName:[FirstName]&" "&[LastName]

Fullname is the label, or alias, for the new field.
[FirstName] and [LastName] are Fields from 
tblCustomer. The two quotes have a space 
between them. 

Query Design Tools ->Design->Results->Run
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.1 Create a Query : Edit Queries

Match Match Match 
The concatenation should have two brackets 
surrounding a Field. For example: [LastName]. What 
happens if they do not match?

2. Try it: Type a Mistake
Right click the FullName Field and Zoom to see the 
code. Please edit the expression as follows:

Delete the last bracket.
Type a brace: }

Click OK to close the Zoom Window. When you 
return to the Query, click Tab on the keyboard. This 
will prompt Access to proof the expression. 

What Do You See? Microsoft Access will alert you 
that this expression is missing a closing parenthesis, 
bracket or vertical bar.

Click OK. keep going...

Memo to Self: Proof your Query and make sure the 
punctuation matches. If you start with a parenthesis 
you need to close with a parenthesis. Same goes for 
brackets.

Query Design Tools ->Design
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.1 Create a Query : Edit Queries

Spelling Counts 
3. Try it: Spell the Field Name Wrong
Right click the FullName Field and Zoom to see the 
code. Please edit the expression as follows:

Delete the last brace: }
Type a bracket: ]
Edit the Field Name. Type: Last Name

Click OK to close the Zoom Window. You should 
return to the Query. 

Try This, Too: Run the Query
Go to Query Design Tools ->Design->Results
Click on Run.

What Do You See? Microsoft Access will ask you to 
Enter Parameter Value for Last Name. This means 
that the database could not find Field for Last Name 
in tblCustomers. The Table has a Field for 
LastName. They do not match.  

Click Cancel. 

OK. OK. That's enough error testing for now. Close 
the sample Select Query without saving.

Query Design Tools ->Design->Results->Run
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Who Should Do the Testing? 
All good software should be tested by real Users. 
Software testing doesn’t require thousands of Users to 
find the flaws or bugs. Pick five people and let them 
try the software. If all five Users fail at the same point, 
you don’t need another 995 people to tell you that 
there’s something wrong with the expression or 
navigation.

In the initial test, you should select people who are not 
upset by failure. 

Some people are not appropriate for software testing. 
They are easily offended by errors. Their bad 
impressions can destroy a good program that needs a 
little more work.

Sample Error: The name of the Form is spelled wrong in the Macro. It should be Movies.
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Errors Are Not Failures 
The reason you are testing the software is to 
discover the weakness in your database. 

Errors are not failures. 

Sometimes Users navigate in ways you did not 
expect and your software simply wasn’t designed 
to take that pathway. You can respond by blocking 
that step, or making it better if it helps your Users 
get the job done.

Sample Error: The name of the Control Source is spelled wrong in the Combo Box Properties
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What Is Success? 
Users come to your software tests expecting 
software that works as well as any other Windows 
program. 

We all learn to expect certain behaviors from the 
computer. An “X” can mean “exit” or close. It can 
also mean, “Don’t do that.” If you use “X” as “X 
marks the spot!” you will confuse your users. This is 

symbol.

Property Sheet Settings for a Sample Form

Comma Training Page 217

Microsoft Access 2013 Inermediate   Page 217 of 281



The Live Performance 
A good piece of software needs little or no 
explanation. Users should be able to navigate 
through the assigned task and complete their work 
efficiently. That's the plan, anyways.

In reality, you should prepare for your software 
launch. Before you release your software, you 
should e-mail the people who will be using your 
database. Explain how the new database works and 
offer them an opportunity to join you in the new 
release. You should give them a method—an e-mail 
form or a phone number—so they can contact you if 
they have any questions. 

A little communication goes a long way. You are 
going to change how they get their work done.   

If you listen to your users when you develop the 
database, and listen again when you test the 
software, then you will be successful. 

Sample Access Database Form
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Summary 
The purpose of software testing is to create a better 
User experience. This lesson mocked up a couple of 
common programming mistakes and looked at the 
different errors.

Troubleshooting database errors can be frustrating 
when you don't see the mistakes right away, but there 
is nothing difficult.

Allez Allez in free.
You done good.
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1. What error is displayed when Access cannot 
match the name with the correct field?
A. #REF
B. #FIELD
C. #NAME?
Tip: Intermediate Access, page 211

2. Two common Query errors are punctuation 
and spelling.
A. True
B. False
Tip: Intermediate Access, page 212

3. When Access prompts for a Parameter Value, 
it  can mean that Access cannot find a matching 
field.
A. True
B. False
Tip: Intermediate Access, page 214

4. Which is true about testing a database.
A. Not necessary
B. Should be done by people not easily upset 
by failure
C. Used to discover weakness in database
Tip: Intermediate Access, page 216

5. Which of the following is true about good 
software?
A. It needs little or no explanation to be used
B. Users should be able to navigate through 
the assigned table and complete their work 
efficiently
Tip: Intermediate Access, page 218 

Test Yourself
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Access 2013: One to Many in Report Design

Intermediate Access Objectives
In this lesson, you will learn how to: 
1. Use the Report Wizard to create a Report based 
on a Select Query.
2. Add Totals for each Group of Records.
3. Add Totals to the Report Footer.

Report Totals

Comma Training Page 221

Microsoft Access 2013 Inermediate   Page 221 of 281



1. Readings
Read Lesson 9 in the Intermediate Access 
guide, page 221-248.

Project
A Report that Totals each Group.

Downloads
FrontRowVideo Int9.accdb
popcorn1.gif, popcorn2.gif, 
popcorn3.gif, popcorn4.gif, movies1.gif

BBL Int ver9.accdb
BB Customers Logo.jpg
Brown Bag Logo.jpg
Lunch1.gif, Lunch2.gif, Lunch3.gif, 
Lunch4.gif

2. Practice
Do the Practice Activity on page 249.

3. Assessment
Review the Test questions on page 250.

Menu Maps
From the Create Ribbon 
1. Create->Reports->Report Wizard, page 230

From the Report Design Tools->Design Ribbon.
1. Report Design Tools->Design-> Grouping and Totals->Group &Sort, page 237
2. Report Design Tools->Design->Views-> View->Print Preview, page 240
3. Report Design Tools->Design->Controls->Label, page 243
4. Report Design Tools->Design->Controls->Text Box, page 246

Report Design Tools->Design Ribbon

Lesson 9 : Report Totals

Comma Training Page 222

Microsoft Access 2013 Inermediate   Page 222 of 281



Example of a Report in Microsoft Office Access

One-to-Many in Reports, Part 1
This course has been looking at ways to represent one-to-many relationships. In our business 
scenario, there are many movies in each Genre. Grouping is a very effective way to represent one-to-
many relationships in a Report.  The first lesson will create a movie report that totals the movies in 
each Genre: how many Westerns, how many Comedies? The next lesson will apply some Report 
Formatting. 

Working with Reports is like working with Forms in Design View: the Tools are very similar. Many of 
the steps may have a sense of déjà vu, particularly if you have been reading this all night! Very well, 
let's create a new Report. 
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What Are the Objectives? 
This Report will be based on a Query that was made 
in an earlier lesson: MoviesSQ. This Query looks up 
information from tblMovies. 

Here are the objectives for this lesson:

Create a Report based on a Query
Review the Query

Create a Report with the Report Wizard
Select MoviesSQ Query as the Record Source

Add Sorting and Grouping
Group the Movies by Genre
Sort the Movies by Year

Add Totals to the Report
Total Each Group
Total for the Report

That's our goals for this lesson. There may be one or 
two more by the time we are done. 

Example of a Calculated Control in a Microsoft Office Access Report
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: View All Access Objects

Before You Begin 
Before You Begin: Open the Sample Database
Go to Start -> Microsoft Access 2013.
Access will prompt you to open a database. 
This lesson uses the database that was programmed in 
the previous lesson. You can continue with the same 
database if you wish. 

The FrontRowVideo Int9.accdb database has:
Five Tables: tblCustomers, tblGenre, tblMovies, 
tblMovieSearch and tblRating.

Six Queries: CustomerHomePhoneSQ, 
CustomerNameSQ, MoviesByYearSQ, MovieSQ, 
MovieSearchSQ and RatingSearchSQ.

Four Forms: Customers, Movies, MovieSearch and 
MovieSearchSubform.

Two Reports: Movies by Year, Customer Name.
Keep going...

Memo to Self: Click Enable Content if you see the 
Security Warning. 

Start -> Microsoft Access 2013
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.2 Modify a Query : Modify a Query

Still Before You Begin 
The best place to start is to review the data. A 
Report is only as good as the information in 
the Table or Query. 

1. Try it: Review the Query
Go to All Access Objects->Queries.
Select a Query: MovieSQ.
Go to Home->Views->View.
Select a View: Design View.

What Do You See? There are five Fields 
selected from tblMovies:
MovieID
Year
Movie
Rating
Genre

Keep going...

Home->Views->View->Design View
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.1 Create a Query: Run Queries

Run the Query 
2. Try it: Run the Query
The Query is open in Design View.
Go to Query Tools ->Design->Results->Run.

What Do You See? The Query returned 401 
Records. The Movies are sorted by Year. 

What Else Do You See? The data is not 
complete. Some of the Movies have a Rating, 
Some do not. Some do not have a Genre.

Close the Query. Keep going...

Query Tools ->Design->Results->Run
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.2 Modify a Query : Modify a Query (Edit Criteria)

Edit the Query Criteria 
This Report is supposed to Group and Total on 
the Genre. We can add a Criteria to the Genre 
Field that filters out all of the ones have a no 
value: they are Null.

Before You Begin: Change the View
Go to Home->View->Views.
Select a View: Design View.

3. Try it: Edit the Query Criteria
Go to the Genre Criteria.
Type: Is Not Null

Keep going...

Home->View->Views->Design View
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Exam 77-424: Microsoft Access 2013
3.0 Create Queries 
3.1 Create a Query: Run Queries (Use Criteria to Filter the Records)

Run the Query, Again 
The Query Criteria, is Not Null, should filter out 
all of the Records that do not have a Genre.

Did it work? Only one way to find out: Run it!

4. Try it: Run the Query
The Query in still open in Design View.
Go to Query Tools ->Design->Results->Run.

What Do You See? The Query returned 374 out 
of 401 Records. All of the Records have a 
Genre, there are no empties (null). 

So, the Query Criteria worked.

What Else Do You See? The Movies are sorted 
by Year. The data is still not complete. Most of 
the Movies have a Rating.

Save your changes and Close the Query.

Let's create a Report and use this Query for the 
Record Source.  

Query Tools ->Design->Results->Run
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.1 Create a Report : Create New Reports (Report Wizard)

Begin the Report Wizard 
The following pages will walk through the Report 
Wizard. Please note the steps that include Sorting, 
Grouping and Totals. 

After we complete the Wizard, we will edit the 
Report in Design View and make a few changes. 

1. Try This: Begin the Report Wizard
Go to Create->Reports->Report Wizard. 
The Wizard will prompt your through the steps to 
design a Report.

Try This, Now: Choose a Record Source
Select a Query: MovieSQ.
All of the Available Fields are selected except the 
MovieID.

Click Next. 

Keep going...

Create->Reports->Report Wizard
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.2 Set Report Controls: Group Data by Fields

Report Wizard: Grouping 
Grouping lets you represent one-to-many. In this 
Report, one Genre has many Movies.

2. Try it: Select the Grouping
Select a Grouping Level: Genre.

What Do You See? The Genre will be placed in a 
separate Group Header on the Report. 

Click Next. 

Keep going...

Create->Reports->Report Wizard
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.2 Set Report Controls: Sort Data

Report Wizard: Sorting
A Report can Sort by more than one Field. 

3. Try it: Select the Sorting
First Sort: Movie.
Sort: Ascending.

What Do You See? The Fields can be sorted 
Ascending or Descending if you wish. 

Keep going...

Create->Reports->Report Wizard
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.1 Create a Report : Create New Reports (Report Wizard)

Report Wizard: Layout 
4. Try it: Select the Layout Options
Layout: Stepped
Orientation: Portrait

Keep going...

Create->Reports->Report Wizard
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.1 Create a Report : Create New Reports (Report Wizard)

Report Wizard: Title  
5. Try it: Finish the Report Wizard
Enter the Title: Movies by Genre.
Preview the report.

Click Finish.

So, turn the page and let's see what we got.

Create->Reports->Report Wizard
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.5 Print and Export a Database: Print Reports

Report Wizard: Print Preview
6. Try it: Review the Print Preview
The Report Wizard is finished and the Report is 
open in Print Preview. 

What Do You See? The Report, Movies by 
Genre, is grouped by Genre and sorted by the 
Movie within each Group. 

The next step is to review the Groups in Design 
View and add Totals to the Group. 

Create->Reports->Report Wizard
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.2 Set Report Controls: Group Data by Fields

Review the Grouping 
In the Report Wizard, we selected one Grouping Level: 
Genre. Let's find that Group now.

Before You Begin: Change the View
Close the Print Preview.
When you close the Print Preview, the Report should be 
open in Design View, as shown on this page.

1. Try it: Review the Grouping Levels
The Report, Movies by Genre, is open in Design View and 
the Report Design Tools are available.

What Do You See? This Report has Sections:
Report Header: There is a label.

Page Header: The labels repeat on top of each page.

Genre Header: Only the Genre Field. 
This is the One in the One-to-Many.

Detail: The Movie and Rating Records.
This is the Many in the One-to-Many.

Page Footer: The Date and Page Number repeat at the 
bottom of every page. 

Home->View->Views->Design View
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.2 Set Report Controls: Group Data by Fields

Grouping and Totals 
This Report has a Group Header. There is one 
Field: Genre. Group Totals are placed in the 
Group Footer. Here are the steps to show or 
hide the Group Footer. 

2. Try it: Add the Group Footer
The Report, Movies by Genre, is still open in 
Design View and the Report Design Tools are 
available.

Go to Report Design Tools ->Design.
Go to Grouping and Totals.
Click on Group & Sort.

What Do You See? A new pane, Group, Sort 
and Total will open at the bottom. 

Group On: Genre.
Sort by: Movie.

Keep going...

Report Design Tools ->Design-> Grouping and Totals->Group &Sort
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.3 Format a Report: Insert Headers and Footers

Add the Group Footer 
Our Report is Grouped on Genre. It is the first 
Grouping in the Group, Sort and Total box at the 
bottom of this Report in Design View. 

3. Try it: Add the Group Footer
Go to Group, Sort and Total.
Select a Group: Genre.
Click on More.

What Do You See? A library of options will drop 
down for the Grouping and Totals.
Select a Footer: With a Footer Section.

What Else Do You See? There should be another 
Section in the Report under the Detail Section: 
Genre Footer.

Nice. Keep going...

Report Design Tools ->Design-> Grouping and Totals->Group &Sort
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.3 Format a Report: Add Calculated Fields (Totals)

Add a Calculated Control 
Our goal is to add Totals for each Group as 
well as for the entire Report. Basically, a Total 
is a Text Box that has an expression instead of 
a Control Source. 

It is a Calculated Control: An Expression that 
Counts the Records in each Group. 

4. Try it: Create a Calculated Control
Go to Group, Sort and Total.
Select a Group: Genre.
Edit the Totals as follows:
Total on: Genre.
Type: Count Values
Show subtotal in Group Footer.

Keep going...

Report Design Tools ->Design-> Grouping and Totals->Group &Sort
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.5 Print and Export a Database: Print Reports

Preview the Group Totals 
5. Try it: Preview the Group Totals
Go to Report Design Tools ->Design->Views.
Select a View: Print Preview.

What Do You See? The Count for each Genre is 
calculated in the Genre Footer. 

In the example on this page, the Genre is Biography 
and the Count is 1. 

Keep going...let's take a look at this.

Report Design Tools ->Design->Views-> View->Print Preview
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.3 Format a Report: Add Calculated Fields (Totals)

Review the Totals for the Group
The previous page shows what the Calculated 
Control looks like in Print Preview, as a User would 
see it. What does it look like to a Programmer, in 
Design View?

Before You Begin: Change the View
Close the Print Preview, please.
When you close the Print Preview, the Report 
should be open in Design View, as shown.

6. Try it: Review the Totals in Group Footer
This Control is an expression that Counts in Genre. 
It can be found in the Group Footer.

Go to the Genre Footer.
Select the Calculated Control:
=Count([Genre])

Where Count is the function,
[Genre] is the Field from MovieSQ.

Keep going...

Home->View->Views->Design View
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.3 Format a Report: Add Calculated Fields (Totals)

Review the Control Property 
7. Try it: Review the Property Sheet
The Calculated Control is still selected.
Go to Report Design Tools ->Design->Tools.
Select a Tool: Property Sheet.

What Do You See? The Property Sheet shows:
Selection Type: Text Box.
Name: AccessTotalsGenre
Control Source: =Count([Genre]).

Keep going...

Report Design Tools ->Design->Tools->Property Sheet
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.3 Format a Report: Add Unbound Fields (Label)

Add an Unbound Control 
The Count works, but it would be easier to understand 
this Report if there was a Label that said what that 
number meant. A Label, like the Calculated Control, is 
Unbound: It does not look up the data in a Table or 
Query.

Before You Begin: Move the Control
Select the Control in the Genre Footer.
Move the Control to make room for the Label. 

8. Try it: Add a Label to the Group Footer
Go to Report Design Tools ->Design->Controls.
Choose a Control: Label.
Go to the Genre Footer.
Click and Draw a Label.

Try This, Too: Edit the Label Properties
Name: GenreTotalLabel
Caption: Count of Movies by Genre.
Width: 2'
Height: 0.2188 (that is default for this type size).
Top: 0"
Left: 0.125

Keep going...

The Label has an exclamation point. 
This alert says that the Label is not 
Associated with a Control. You can 
bind it to the AccessTotalGenre.

Report Design Tools ->Design->Controls->Label
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.3 Format a Report: Add Unbound Fields (Label)

Preview the Results 
9. Try it: Preview the Report
Go to Report Design Tools ->Design->Views.
Select a View: Print Preview.

What Do You See? The Label is visible in the 
Genre Footer, next to the Count of the Genre. 

Do This, Now: Save the Report.
Go to File->Save.

Keep going...Let's add a Total for the Report.

Report Design Tools ->Design->Views-> View->Print Preview
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.3 Format a Report: Add Calculated Fields (Totals)

Edit the Report Footer
Each Group has a separate Footer. We added 
a Calculated Control to the Group Footer to 
Count the Records in that Group. The Report 
Totals are added to the Report Footer. Here 
are the steps.

Before You Begin: Change the View
Close the Print Preview, please. The Report 
should be open in Design View.

1. Try it: Edit the Report Footer
Select the Report Footer.
Edit the Following Property:
Height: 0.5"

What Do You See? There should be a Report 
Footer at the bottom. 

Keep going...

Report Design Tools ->Design->Tools->Property Sheet
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.2 Set Report Controls: Add Report Controls

Add a Text Box to the Footer 
A Calculated Control is a Text Box with an 
Expression for the Control Source.

2. Try it: Add a Text Box to the Footer
Movies by Genre is still open in Design View.
Go to Report Design Tools ->Design.
Select a Control: Text Box.
Click in the Report Footer.
Draw a Text Box.

What Do You See? There should be a new, 
unbound Control in the Report Footer.

Keep going...

Report Design Tools ->Design->Controls->Text Box
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.3 Format a Report: Add Calculated Fields (Totals)

Edit the Text Box Properties 
3. Try it: Edit the Text Box Properties
The unbound Text Box is still selected.
Edit the following Properties:
Name: ReportTotalsGenre
Control Source: =Count([Genre])

Try This, Too: Edit the Label
Select the Text Box Label.
Edit the following Properties:
Name: ReportTotalsLabel.
Label: Total Count by Genre.

What Do You See? This Calculated Control looks 
likes it is ready. Let's see if it sings.

Keep going...

Report Design Tools ->Design->Tools->Property Sheet
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.3 Format a Report: Add Calculated Fields (Totals)

See the Report in Print Preview
The Report Totals are placed at the end of the 
Report. Let's see how this worked.

4. Try it: Preview the Report
Go to Report Design Tools ->Design->Views.
Select a View: Print Preview.
Use the Record Selectors to go to the last page of 
this Report to see the Report Totals. 

What Do You See? The last Group in the Report is 
Westerns. There is only 1 Record in the Western 
Group. 

The Total Count is 374. That is the same number of 
Records we got when we ran the Query, MovieSQ, 
and reviewed the results at the beginning of this 
lesson. 

Do This, Now: Save the Report.
Go to File->Save.

OK, get a cookie! 

Report Design Tools ->Design->Views-> View->Print Preview
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Lesson 9: One to Many in Report Design
Try This: Do the following steps
1. Open the Brown Bag Lunch database you have been working on. 
Or, you may download Brown Bag Lunch ver9.accdb. 
2. Begin the Report Wizard. Choose the record source: ItemSQ Query.
3. Select all available fields EXCEPT ProductID.
4. Select Grouping by Specialty, then Grouping by Type.
5. Sort Items in Ascending Order.
6. Select Layout: Stepped.
7. Enter the Title: Products by Specialty. Finish the Wizard and Preview the Report.
8. Close the Preview and go to Design View.
9. Use the Group & Sort command. Add the option With a Footer Section.
10. Edit the options for totals:
Total on: Specialty
Type: Count Value
Show Subtotals in Group Footer
11. In the Group Footer (ie. Specialty Footer)’ add an Unbound label next to the Control. 
Change the text to say Count of Products by Specialty. In the Property Sheet, change the 
name to SpecialtyTotalLabel.
12. Select the Report Footer. Add an Unbound control. Add the control =COUNT([Specialty])
13. In the Property Sheet, change the name to ReportTotalLabel. Change the caption to Total 
County by Specialty.
14. Preview the Report. Save the Report.
15. Save and Close the database.

Practice Activity
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1. Which criteria Filters out all blank records for 
that Field?
A. Is Not Null
B. No Blanks
C. Is Not Empty
Tip: Intermediate Access, page 228

2. Which Report Options let you represent the 
one-to-many relationship?
A. Options
B. Grouping
C. Header
D. Priority
Tip: Intermediate Access, page 231

3. Which of the following is a part of an Access 
Report? (Give all correct answers.)
A. Report Header 
B. Page Header
C. Group Header (i.e. Genre Header)
D. Detail
E. Page Footer
F. Report Footer
G. Group Footer
Tip: Intermediate Access, page 237

4. Which is true about Access Reports?
(Give all correct answers.)
A. The Group, Sort and Total shows Group Totals
B. The Group Footer includes the Group, Sort and 
Total command
Tip: Intermediate Access, page 237, 238

5. A Label must always be attached to a Field and 
a Record Source.
A. True
B. False
Tip: Intermediate Access, page 243

Test Yourself
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© 2014 Comma Productions, LLC

Access 2013: One to Many in Report Design

Intermediate Access Objectives
In this lesson, you will learn how to: 
1. Apply Report Design options including 
Theme, Logo, and a Background Image.
2. Add Page Breaks and Page Numbers.
3. Apply Conditional Formatting to the data.
4. Program a Command Button to open a 
Form OnClick and format the Shape.

Report Design Options
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1. Readings
Read Lesson 10 in the Intermediate Access 
guide, page 251-275.

Project
A Report with Conditional Formatting as 
well as a Command Button that opens a 
Form with an OnClick Event.

Downloads
FrontRowVideo Int10.accdb
popcorn1.gif, popcorn2.gif, 
popcorn3.gif, 
opcorn4.gif, movies1.gif.

BBL Int ver10.accdb
BB Customers Logo.jpg
Brown Bag Logo.jpg
Lunch1.gif, Lunch2.gif, Lunch3.gif, 
Lunch4.gif

2. Practice
Do the Practice Activity on page 276.

3. Assessment
Review the Test questions on page 277.

Menu Maps
From the Report Design Tools->Design Ribbon
1. Report Design Tools->Design->Themes, page 257
2. Report Design Tools ->Design->Views-> View->Print Preview, page 262

From the Report Design Tools->Format
1. Report Design Tools->Format->Conditional Formatting->Shape Fill, page 258
2. Report Design Tools->Format->Conditional Formatting->Shape Outline, page 258
3. Report Design Tools->Format->Background->Background Image, page 263
4. Report Design Tools->Format->Control Formatting->Conditional Formatting, page 264
5. Report Design Tools ->Format->Control Formatting->Change Shape, page 272
6. Report Design Tools ->Format->Control Formatting->Quick Styles, page 273

Report Design Tools->Design

Report Design Tools->Format

Lesson 10 : Report Design and Formatting
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Designing Reports
The Report may be the only part of your Mighty Access database that your customers ever see. 
Like a stage play, most of the database is "backstage." This lesson uses the Report Tools to 
format your printouts. Many of the options are similar to the ones we used earlier in the Form 
Design. Reports, like Forms, can have Command Buttons, too. Our report will have a Command 
Button that opens a Form. 

Report Design and Formatting

Microsoft Access: Example of a Microsoft Access Report
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What Are the Objectives?
Microsoft Access has an impressive array of Report 
Design Tools. This lesson will use the Design and 
Format Ribbons.

Apply Report Design Options:
Apply a Theme to the Report
Edit the Color and Fonts
Insert a Page Break
Format the Page Numbers

Apply Report Format Options:
Apply a background image to the Report
Add a Shape
Apply Conditional Formatting to the data

That's the plan. 

Microsoft Access: Example of a Microsoft Access Report
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: View All Access Objects

Before You Begin 
Before You Begin: Open the Sample Database
Go to Start -> Microsoft Access 2013.

Access will prompt you to open a database. This lesson 
uses the database that was programmed in the previous 
lesson. You can continue with the same database if you 
wish. 

The FrontRowVideo Int10.accdb database has:
Five Tables: tblCustomers, tblGenre, tblMovies, 
tblMovieSearch and tblRating.

Six Queries: CustomerHomePhoneSQ, 
CustomerNameSQ, MoviesByYearSQ, MovieSQ, 
MovieSearchSQ and RatingSearchSQ.

Five Forms: Customers, Movies, MovieSearch, 
MovieSearchSubform and the Switchboard.

Three Reports: Customer Name. Movies by Genre, and 
Movies by Year. 

Memo to Self: Click Enable Content if you see the 
Security Warning. 

Start ->Microsoft Access 2013

Comma Training Page 255

Microsoft Access 2013 Inermediate   Page 255 of 281



Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.3 Format a Report: Modify Existing Reports (View Properties)

Review the Report 
The last time we left our hero, the Movies by Genre 
Report, the basic design was complete.

1. Try it: Review the Report Design
Go to All Access Objects->Reports.
Select a Report: Movies by Genre.

Try This, Now: Change the View:
Go to Home ->Views->View->Design View.
The Report Design Tools should be available.

What Do You See? This Report has Sections:
Report Header: There is a label.

Page Header: These labels repeat at the top of 
every page.

Genre Header: Only the Genre Field. 
This is the One in the One-to-Many.

Detail: The Movie and Rating Records.
This is the Many in the One-to-Many.

Page Footer: The Date and Page Number repeat at 
the bottom of every page. 

Home ->Views->View->Design View
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.3 Format a Report: Apply Themes

Apply A Theme 
2. Try it: Apply a Theme to a Report
Go to Report Design Tools->Design->Themes
Select a Theme: Retrospective

What Do You See? A Theme formats the Color 
as well as the Fonts for the Report. 

What Else Do You See? Some Fonts may 
make the Text in the Labels too large to fit. You 
can resize the Labels if you wish. 

Made You Look: The Theme will be applied to 
the Switchboard Form as well as the Report. 

Each Theme has a different way of formatting 
the Command Buttons. 

Keep going...

Report Design Tools->Design->Themes
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.3 Format a Report: Modify Themes

Modify a Theme 
3. Try it: Modify the Theme Colors
The Report is still open in Design View.

Select the Report Header.
Go to Report Design Tools->Format.
Go to Conditional Formatting->Shape Fill.
Select a Fill Color: white.

Select the Label in the Report Header.
Go to Report Design Tools->Format.
Go to Conditional Formatting->Shape Fill.
Select a Fill Color: red.

The Label in the Report Header is selected.
Go to Report Design Tools->Format.
Go to Conditional Formatting->Shape Outline. 
Select an Outline Color: orange.

The Label in the Report Header is selected.
Go to Report Design Tools->Format->Font. 
Select a Font Color: white.

Keep going...

Report Design Tools->Format->Conditional Formatting->Shape Fill
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.3 Format a Report: Modify Headers and Footers

Find the Page Numbers
Page Numbers were added to the Page Footer as we 
walked through the Report Wizard.

4. Try it: Find the Page Numbers
The Report is still open in Design View.
Select the Page Number Control in the Page Footer. It 
is a Text Box.
Go to Report Design Tools->Design->Tools.
Go to Property Sheet->All->Control Source.

What Do You See? The Page Numbers are displayed 
in a Text Box that has an Expression for the Control 
Source. 

The Expression for the Pages Numbers is:
="Page " & [Page] & " of " & [Pages]

Keep going...

Report Design Tools->Design->Tools->Property Sheet
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.3 Format a Report : Add Calculated Fields (Use the Expression Builder)

Edit the Expression 
This Expression is similar to ones we created earlier in 
various Select Queries. You can edit the text between 
the quotation marks if you wish.

5. Try it: Find the Page Number Properties
The Movies by Genre Report is in Design View and 
the Page Number Control is selected.
Go to Property Sheet->All.
Click on Control Source.
Click on the 3-Dot Builder.
The Code Builder should open.

Try This, Too: Edit the Expression
Type Movies by Genre Report between the quote 
marks as follows:

="Movies by Genre Report: Page " & [Page] & " of " & 
[Pages]

Where the Expression is one sentence without line 
breaks as may be printed in the preceding paragraph, 
above.

Click OK to close the Expression Builder.
You should return to the Report in Design View. 

Report Design Tools->Design->Tools->Property Sheet
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.3 Format a Report: Modify Headers and Footers (Insert a Page Break)

Add a Page Break
You can use a Page Break to make each new 
Genre begin at the top of the next Section. There 
are two ways to add a Page Break to a Report: a 
Page Break Control or selecting that option in the 
Property Sheet.

This example will use the Property Sheet to add a 
Page Break AFTER the Genre Footer Section.

6. Try it: Add a Page Break
The Movies by Genre Report is in Design View.
Select a Section: Genre Footer.
The Genre Footer bar should be black.

Go to Property Sheet->Format.
Edit Force New Page: After Section.

That should do it.

Do This, Now: Save the Report
Go to File->Save.

Keep going...

Report Design Tools->Design->Tools->Property Sheet
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.5 Print and Export a Database: Print Reports

Preview the Report 
The proof is in the pudding. Let's look at this 
Report as a User would see it: Print Preview.

7. Try it: Preview the Report
Go to Report Design Tools ->Design->Views.
Select a View: Print Preview.

What Do You See? Each Genre begins a new 
Section at the top of a page.

What Else Do You See? The Page Number in the 
Genre Footer should include our edits.

Not bad. Not bad.

Report Design Tools ->Design->Views-> View->Print Preview
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.3 Format a Report: Add Backgrounds

Add a Background Image
As we mentioned at the beginning of this 
lesson, the Report may be the only part of your 
Mighty Access Database that your customers 
or coworkers see. Dress it up!

Reports, like Forms, can be branded with 
images. Here are the steps to add a 
Background Image to this Report. 

Before You Begin: Change the View
Close the Print Preview, please.
The Report should be in Design View, now.

1. Try it: Add a Background Image
Go to Report Design Tools->Format.
Go to Background->Background Image.
Browse for an Image: popcorn4.jpg.
Click OK.

What Do You See? The popcorn image 
should be behind the Controls and Labels.

Report Design Tools->Format->Background->Background Image
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.2 Set Report Controls: Use Conditional Formatting

Use Conditional Formatting
Conditional Formatting changes the Font Color of 
the Control depending on the Rules that you set 
up. You can use Conditional Formatting in a 
Report as well as in a Form.

This Rule will be applied to the Rating data, as we 
did earlier on the MovieSearchSubform.

2. Try it: Use Conditional Formatting
The Report is still open in Design View.
Select the Rating Control in the Detail Section.
Go to Report Design Tools->Format.
Go to Control Formatting.
Click on Conditional Formatting.

What Do You See? The Conditional Formatting 
Rule Manager will prompt you to create a New 
Rule. 

Keep going...

Report Design Tools->Format->Control Formatting->Conditional Formatting
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Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.2 Set Report Controls: Use Conditional Formatting

Edit the Formatting Rule
Each value in the Rating data will be 
assigned a different color.

3. Try it: Edit the Formatting Rule
Field Value is: equal to
Enter the Rating: G
Format the color: green

Keep going...

Memo to Self: Be consistent. We used 
Conditional Formatting in the Movie 
Search Subform. It is OK to match the 
colors in the Report. 

Report Design Tools->Format->Control Formatting->Conditional Formatting

Comma Training Page 265

Microsoft Access 2013 Inermediate   Page 265 of 281



Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.2 Set Report Controls: Use Conditional Formatting

Add More Rules 
4. Try it: Add More Rules
Add a Rule for the PG Rating
Click on New Rule.
Field Value is: equal to
Enter the Rating: PG
Format the color: orange

Add a Rule for the R Rating
Click on New Rule.
Field Value is: equal to
Enter the Rating: R
Format the color: red

Show formatting rule for Rating:
There should be three rules.

Click OK. Keeeeeep going. 

Report Design Tools->Format->Control Formatting->Conditional Formatting

Comma Training Page 266

Microsoft Access 2013 Inermediate   Page 266 of 281



Exam 77-424: Microsoft Access 2013
5.0 Create Reports 
5.2 Set Report Controls: Use Conditional Formatting

Print Preview the Formatting 
5. Try it: Preview the Report
Go to Report Design Tools ->Design->Views.
Select a View: Print Preview.

What Do You See? Each Genre begins a new 
Section at the top of a page. The Count in each 
Section is shown in the Genre Footer.

What Else Do You See? The Rating data is formatted 
according to the Conditional Formatting Rules: G is 
green, R is red.

Please Close the Print Preview. 

Report Design Tools ->Design->Views-> View->Print Preview
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Use Navigation Buttons

Designing for Users 
A Report is a snapshot, at best, of the data. 

A Command button can open the Movie Search 
Form so that Users can look up the answer. The 
Command Button in this example will use a Macro 
to open the MovieSearch Form. We will also 
format the Command Button with Quick Styles. 

1. Try it: Create a Macro
Go to Create ->Macros & Code->Macro.

What Do You See? The Macro Window should 
open. The Action Catalog is on the left. It lists 
many things you can program:
Data Entry Operations
Data Import/Export
Database Objects
Filter Query Search
Macro Commands
System Commands
User Interface Commands
Windows Management

Keep going...

Create ->Macros & Code->Macro
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Use Navigation Buttons

Program the Macro 
2. Try This: Program the Macro
Go to the Action Catalogue.
Go to Database Objects.
Double Click an Action: OpenForm

The OpenForm Action will prompt you to 
select the following from the list:
Form Name: MovieSearch

Do This, Now: Save the Macro
Go to File->Save.
Enter a name: OpenSearchMovie

Now, Try This: Run the Macro
Go to Macro Tools ->Design->Tools.
Click on Run (!)

What Do You See? Did the Movie Search 
Form open? Then it worked. 

Please Close the Movie Search Form.
Close the Macro

Keep going...

Macro Tools ->Design->Tools->Run
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Use Navigation Buttons

Add a Command Button 
This Command Button will be added to the Report 
Header. In the Properties, the new Macro will be added 
to the OnClick Event. 

Before You Begin: The Movies by Genre Report is in 
Design View. The Report Tools are available. 

3. Try This: Add a Command Button
Go to Report Design Tools ->Design->Controls.
Click on Command Button.
Click in the Report Header. 
You should see a new, unbound Button. 

Try This, Too: Edit the Command Button
The Command Button is selected.
Go to Property Sheet->All. Edit the following:
Name: SearchMovie
Caption: Search the Movies
Width: 1.5
Height:0.25
Top: 0.25
Left: 2.25

Keep going...

Report Design Tools ->Design->Tools->Property Sheet
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Program Navigation Buttons

Add the OnClick Event 
4. Try it: Add the OnClick Event
The Command Button is selected.
Go to Property Sheet->Event. 
Click on: On Click.

What Do You See? The OpenSearchMovie 
Macro is on the list. 

Select a Macro: OpenSearchMovie.

Do This, Now: Save, Save, Save. 
Go to File->Save. 

Report Design Tools ->Design->Tools->Property Sheet->Event
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Format Navigation Buttons (Change Shape)

Change the Shape of the Button 
A Command Button is a Shape. The default Shape for 
a Command Button is a rectangle with rounded 
corners. The Shape can also be a circle or a rectangle 
with one corner snipped. 

Look at the Label in the Report Header: It is a 
rectangle that is red with an outline. Let's format the 
Command to match it. 

5. Try it: Change the Shape of the Button
The Command Button is selected.
Go to Report Design Tools ->Format. 
Go to Control Formatting->Change Shape.
Choose a Shape: Rectangle.

Keep going...

Report Design Tools ->Format->Control Formatting->Change Shape
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Exam 77-424: Microsoft Access 2013
1.0 Create and Manage a Database 
1.3 Navigate Through a Database: Format Navigation Buttons (Quick Styles)

Apply Quick Styles to a Shape
Microsoft Office has a rich gallery of Quick Styles
in Word, Excel, PowerPoint, Outlook and Access. 

Quick Styles edit the Shape Outline, Fill and 
Effects. It is fun to find the Quick Styles and apply 
them to a Command Button in Access. 

Here are the steps to format a Command Button 
with Quick Styles. Have fun!

6. Try it: Apply Quick Styles to a Shape
The Command Button is selected.
Go to Report Design Tools ->Format. 
Go to Control Formatting->Quick Styles.
Choose a Quick Style: Subtle Effect-Orange, 
Accent 1.

Soooo, how does it look?

Report Design Tools ->Format->Control Formatting->Quick Styles
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Try the Command Button 
Before You Begin: Change the View
This Command Button works in the Report View, 
not the Design View or the Print Preview.

Go to Report Design Tools ->Design->Views.
Select a View: Report View.

7. Try This: Open the Movie Search Form
The Report has a Command Button in the 
Report Header.
Click on: Search the Movies.

What Do You See? Did the Movie Search Form 
Open? Really? 

Well, you might as well Save it if it worked.

Report Design Tools ->Design->Views-> View->Report View
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One-to-Many Designs 
The Intermediate Guide to Microsoft 
Access 2013 began with a simple Access 
database: two Tables, two Forms and Two 
Reports. In just ten lessons we have 
programmed:

A Combo Box to filter the Movies
(One Rating from Many in tblRating)

A Movie Search Form that uses two 
synchronized Combo Boxes to look up 
Movies. This Form has a Subform to 
represent the one-to-many relationship. 
(One Rating many Movies)

A Switchboard that uses Command 
Buttons to open Forms and Reports

Finally, many of the same options were 
designed into several Reports.

You done good. You get the cookie!
Please join me for the Advanced Guide to 
Microsoft Access 2013 where we get down 
to business: working with money.
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Lesson 10: Report Design Options
Try This: Do the following steps
1. Open the Brown Bag Lunch database you have been working on. Or, you may download 
BBL Int ver10.accdb. 
2. Open the Report Products by Specialty. Go to Design View.
3. Apply a Theme of your choice to the Report.
4. Modify the Theme by changing the following with colors of your choice:
Report Header back color
Fill color, outline color, and font (fore) color of the Report Header Label
5. Force a New Page after the Specialty Footer Section.
6. Add a background image: Lunch2.gif
7. Add Conditional Formatting to the Specialty column as follows:
Gluten Free has orange text
Vegetarian has green text
Low-Fat has pink text
8. Create a Macro that opens the Form Product Search. Name the Macro: 
ProductSearchForm.
9. Add a Command Button to the Report Header with the text Search Products. Use the 
Macro ProductSearchForm. 
10. Change the Search Products button’s shape and apply a Quick Style of your choice. 
11. Test the Command Button. Does it open the Product Search Form?
12. Save the Report.
13. Save and Close the database.

Practice Activity
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1. After applying a Theme, you cannot edit the 
colors of items on the Report.
A. True
B. False
Tip: Intermediate Access, page 258

2. Which are methods of adding a page break? 
(Give all correct answers.)
A. Insert a Page Break Control
B. Use the Property Sheet
Tip: Intermediate Access, page 261

3. Which Ribbon has the command for adding a 
background image?
A. Report Design Tools-> Design
B. Report Design Tools-> Arrange
C. Report Design Tools-> Page Set Up
D. Report Design Tools-> Format
Tip: Intermediate Access, page 263

4. Which tool is used to create a Command 
button on a Report that opens a Form?
A. Command Button editor
B. Report Controls
C. Macro Builder
Tip: Intermediate Access, page 268, 270

5. Which is true about a Command Button on a 
Form? (Give all correct answers.)
A. You can change the Shape of the Button
B. You can apply a Quick Style to the Button
C. You can program a Macro for the Button
Tip: Intermediate Access, page 269, 272, 273

Test Yourself
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5. Create a Report using the Report Wizard. 
Select the Query MoviesSQ as the Record Source. 
Select all available Fields EXCEPT MovieID.
Group by Year.
Sort the Movie Field in Ascending order.
Set the Layout to Stepped.
Name the Report as Movies by Year. 
Finish the Report Wizard and Close the Print Preview. 

6. Edit the Properties for the Label in the Header: Left: 2”, Top 0.25.

7. Add a Logo to the Header. Use the movies1.gif.. 
Edit the Properties for the Logo in the Header: 
Left: 2”, Top 0.25, Width 1.5”, and Height 1.25”. 

8. Format the Report with a Style: Pushpin.
Edit the Properties for the Header: Height: 1.5”.
Save the Report and test it in Print Preview. Close the Report. 

9. Open the Switchboard Form in Design View.
Add a Command Button that opens the Movies by Year Report.
Choose Print Preview
Use text on the Button: Print Movies Report
Name the Button: PreviewMoviesReport
Edit the Button properties: Left: 3”, Top 1”, Width 2”, and Height 0.4”. 
Save the Switchboard Form and test the Form in Normal View.

10.Close the Intermediate Access Skill Test.accdb. 
Submit this database on

Before You Begin: Download and open the sample database
Intermediate Access Skill Test.accdb

1. Open the Switchboard Form in Design View.
Add a Command Button that opens the MovieSearch Form.
Choose to show all Records
Use text on the Button: Search the Movies
Name the Button: OpenFormSearchMovies

2. Edit the Command Button Properties: 
Left: 3”, Top 0.5”, Width 2”, and Height 0.4”. 

3. Edit the Search Button On Click Event with the three-dot builder.
Edit the OpenFormSearchMovies Embedded Macro. 
Add a new step to Close the Switchboard after the Movie Search Form is 
opened; Change Prompt to Don't Save.  Save the Switchboard Form.

4. Return to Form View and test each command button. 
Does the right Form open? Does the Switchboard close when the other 
Form opens? 

Intermediate Access Skill Test

Access 2010 Intermediate Skill Test
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Intermediate Microsoft Access 2013: Index
             Microsoft Office Specialist (MOS): Exam 77-424 for Access 2013

Forms: Change Margins, Pg 105
Forms: Create Forms with Application Parts, Pg 65
Forms: Delete a Form, Pg 318

Manage Records: Append Records, Pg 282
Manage Records: Group Records, Pg 165
Manage Records: Update Records, Pg 45

Print and Export: Export into Alternate Formats, Pg 
255
Print and Export: Print Reports, Pg 336
Print and Export: Save Database to an Exteranl 
Location, Pg 316

Protect and Maintain: Backup, Pg 292
Protect and Maintain: Compact, Pg 341
Protect and Maintain: Encrypt with a Password, Pg 
335
Protect and Maintain: Repair, Pg 341
Protect and Maintain: Split, Pg 326

Queries: Create a Crosstab Query, Pg 248
Queries: Create an Action Query, Pg 44
Queries: Delete a Query, Pg 304
Queries: Format Fields,
Queries: Hide Fields, Pg 289
Queries: Rename a Query, Pg 302
Queries: Use Basic Operators (Add, Subtract, 
Multiply, Divide), Pg 166
Queries: Use Comparison Operators, Pg 222

Relationships: Create and Modify Relationships, Pg 80
Relationships: Enforce Referential Integrity, Pg 81
Relationships: Set Foreign Keys, Pg 39
Relationships: View Relationships, Pg 76

Reports: Add a Subreport, Pg 204
Reports: Create a Report with Application Parts, Pg 204
Reports: Delete a Report, Pg 318
Reports: Modify Data Source, Pg 168
Reports: Set Margins, Pg 170

Tables: Change Data Format, Pg 296
Tables: Change Field Data Types, Pg 296
Tables: Create a Table, Pg 73
Tables: Create Linked Tables from External Sources, Pg 322
Tables: Format a Table, Pg 57
Tables: Hide Fields, Pg 56
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